summaryrefslogtreecommitdiff
path: root/app-emulation/runv/runv-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/runv/runv-0.7.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/runv/runv-0.7.0.ebuild')
-rw-r--r--app-emulation/runv/runv-0.7.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/runv/runv-0.7.0.ebuild b/app-emulation/runv/runv-0.7.0.ebuild
new file mode 100644
index 000000000000..3df1bcf0df82
--- /dev/null
+++ b/app-emulation/runv/runv-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/runv"
+
+inherit autotools golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/runv"
+SRC_URI="https://github.com/hyperhq/runv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ pushd src/github.com/hyperhq/runv/ || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/github.com/hyperhq/runv/ || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/github.com/hyperhq/runv/
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/runv
+}