summaryrefslogtreecommitdiff
path: root/app-emulation/runv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/runv
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/runv')
-rw-r--r--app-emulation/runv/Manifest4
-rw-r--r--app-emulation/runv/metadata.xml15
-rw-r--r--app-emulation/runv/runv-0.7.0.ebuild45
3 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/runv/Manifest b/app-emulation/runv/Manifest
new file mode 100644
index 000000000000..7985d423f3b2
--- /dev/null
+++ b/app-emulation/runv/Manifest
@@ -0,0 +1,4 @@
+DIST runv-0.7.0.tar.gz 1143867 SHA256 13107bdcaa2217f870c3b4a18d490984eea1e372947d7e4725aab1166d366697 SHA512 1303d4ca99186d9f5c1db4257acecf1702546a084942cc4c51de8685c6841da45be72c78f32ab38e2addb80dc40fe4d022d0fcae7b7d6b6d62a30f434cea178c WHIRLPOOL a5a7eabeeccab89b5202cad0762f366fd80d6eb52552681124eb636809b28444855561a5849429f78643b14eba576323c7999f2c892caaf5211505e80f72d928
+EBUILD runv-0.7.0.ebuild 947 SHA256 b8746fc87ed1f497b720f5955b578b40be6bcfee2957de1bb70bef39e6350358 SHA512 be820826c8ca3e46afef230444551dc4b4dd749692b4b6af136d33d7cb527278245346d6a7d4b8e1411219b9ef9212806c612a5dabe5166ecbaeff4cc2e18357 WHIRLPOOL b6462d986e75408a629a8a6fc329ea2c280bc535d33a90a8bd96abf77f148ff2711279a67768b7ac6c4e7f4503433c62b8866bcc8c5450112d3af8f599f5bb0e
+MISC ChangeLog 303 SHA256 68c7cc22f7e67848bf419decd30da668333a85f6f834c7827f20c28697e0a08d SHA512 f65e527d218d93243f84a532a203b7e64a9c075d54b83775870b63a6829410697c4313458623bdf303463ac8ad62602f330acb328d755eb11bae21cfe3563f7e WHIRLPOOL 328fda5d6cfd5207e27034fc558a4b5ac6adc4b298f0cd7606af91efa7377aaa5e9d03cb37693a9ec4ec296c9bcfa016ebd5f06b0e1515796dd97225a8ca881f
+MISC metadata.xml 466 SHA256 2b2a1eb2377513e44b2d7b7a9bec029279894b2cf262333c88533ac1e8846026 SHA512 7bfef834ac0c2ed4c69a5e222ae403448d9a5748d0d086863ea8524efe334ff6926defad5503ad0f0deb97cf5a2f427c0c37c59f1af92bebadc0780b1d41ee95 WHIRLPOOL 07dfeb4490ef10b0cc007aa849a1f8320f6963c9546744710a07e392c71bbf5077ec483f99365f18526d3964e7759b003208d7298fcc680fe7c10b2f4bb3d836
diff --git a/app-emulation/runv/metadata.xml b/app-emulation/runv/metadata.xml
new file mode 100644
index 000000000000..648b9cef5dc9
--- /dev/null
+++ b/app-emulation/runv/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <use>
+ <flag name="libvirt">Enable support for KVM via libvirt</flag>
+ <flag name="xen">Enable support for the Xen Hypervisor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hyperhq/runv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/runv/runv-0.7.0.ebuild b/app-emulation/runv/runv-0.7.0.ebuild
new file mode 100644
index 000000000000..3df1bcf0df82
--- /dev/null
+++ b/app-emulation/runv/runv-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/runv"
+
+inherit autotools golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/runv"
+SRC_URI="https://github.com/hyperhq/runv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ pushd src/github.com/hyperhq/runv/ || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/github.com/hyperhq/runv/ || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/github.com/hyperhq/runv/
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/runv
+}