summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 08:32:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 08:32:11 +0100
commitb785380f2fe77ee428bed67bf6a2d43212dda192 (patch)
tree42ca86e262c14ac83a3ee0bb0051b9862f6f66b4 /app-emacs
parent91e1f8a90b85372d757efd9a1fb7dd1685ea6b50 (diff)
gentoo auto-resync : 17:08:2022 - 08:32:11
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin60134 -> 60299 bytes
-rw-r--r--app-emacs/uxntal-mode/Manifest4
-rw-r--r--app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el4
-rw-r--r--app-emacs/uxntal-mode/metadata.xml14
-rw-r--r--app-emacs/uxntal-mode/uxntal-mode-0.2.ebuild19
5 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 954dc86b8513..597762a410b9 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/uxntal-mode/Manifest b/app-emacs/uxntal-mode/Manifest
new file mode 100644
index 000000000000..3b0a1173b4f3
--- /dev/null
+++ b/app-emacs/uxntal-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50uxntal-mode-gentoo.el 179 BLAKE2B 1f3cbd08b8c649a57d9395e3a1fe41d2b67bc9b4d0c3273ee3cdb275545ecbad873dacf42b496a16fac4901e83c091c5fdc99b1ccc8db31e514054827b0875bc SHA512 07fd8a4cf9e26eb28fbf94ee05d460f7b17712972c081f17bbdcf92fb6ec0363b870f017fa7f1ae5fe401b5116056204baf014240196ac426f1534382e2a75c1
+DIST uxntal-mode-0.2.tar.gz 9450 BLAKE2B b8c3517f452c087aafce7fb1f0dd3dceca5160db27c59b24e1eb46eb0496768b330ab5a741fa809284817a3adcf1e4a46a16c6ec44e8d687f299b63e680eca46 SHA512 4f84a67831c9a43361849185c2ab097174a66c70bd2fd57ca175cb46977be5fef2797d52bd70ea6854a69c99cf94faaa8aa5a6f38ef306e895a42ae62de590a9
+EBUILD uxntal-mode-0.2.ebuild 439 BLAKE2B c69fa5668beff15b919819bba6cc2d7ce8f6b4c9135d76f20119ca24e03ca10b3e3851f6585e0bc064b2df0958bfd766475622918c29003316de199cc9c1b00e SHA512 a9a4db19aca4b3cad96bdacd77fe546bbc2319595cd8d5d94ebb61513f8315b8eead1a502f9014b65fb0e26a9346da6960575a55c8c1b20ca89d8268a9a2f1d7
+MISC metadata.xml 445 BLAKE2B b3cd562c480e527b4b3e0fc8b4306dcfc6b1d0902ee3003b89dcf07ea1331f30d7345f9ad16bd99facc0deb99d58eca650e0550528517eb71e50ad7e661708c6 SHA512 14a59dbac9d1c534eb8dd32dc7292354bda8cdef9495a04973d9f7feeb67f6967737fa5f271a92b4dcb11741b7ddce926a138b948bbe0edd7e35cc258d3ba6b0
diff --git a/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el b/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el
new file mode 100644
index 000000000000..916ad70e1619
--- /dev/null
+++ b/app-emacs/uxntal-mode/files/50uxntal-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'uxntal-mode "uxntal-mode"
+ "Major mode for editing Uxntal files." t)
+(add-to-list 'auto-mode-alist '("\\.tal\\'" . uxntal-mode))
diff --git a/app-emacs/uxntal-mode/metadata.xml b/app-emacs/uxntal-mode/metadata.xml
new file mode 100644
index 000000000000..d8c98f52eae3
--- /dev/null
+++ b/app-emacs/uxntal-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/non/uxntal-mode/issues/</bugs-to>
+ <remote-id type="github">non/uxntal-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/uxntal-mode/uxntal-mode-0.2.ebuild b/app-emacs/uxntal-mode/uxntal-mode-0.2.ebuild
new file mode 100644
index 000000000000..27a4bd542e1d
--- /dev/null
+++ b/app-emacs/uxntal-mode/uxntal-mode-0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for the uxntal assembly language"
+HOMEPAGE="https://github.com/non/uxntal-mode/"
+SRC_URI="https://github.com/non/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"