summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
commit91e1f8a90b85372d757efd9a1fb7dd1685ea6b50 (patch)
treeebeff59a4470abb242c47417f217e36e21fe6a0c /app-emacs
parentae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (diff)
gentoo auto-resync : 17:08:2022 - 02:31:41
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin59788 -> 60134 bytes
-rw-r--r--app-emacs/company-ebuild/Manifest5
-rw-r--r--app-emacs/company-ebuild/company-ebuild-0.1.0.ebuild30
-rw-r--r--app-emacs/company-ebuild/company-ebuild-9999.ebuild30
-rw-r--r--app-emacs/company-ebuild/files/50company-ebuild-gentoo.el5
-rw-r--r--app-emacs/company-ebuild/metadata.xml16
-rw-r--r--app-emacs/exec-path-from-shell/Manifest4
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild24
-rw-r--r--app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el2
-rw-r--r--app-emacs/exec-path-from-shell/metadata.xml20
-rw-r--r--app-emacs/markdown-mode/Manifest2
-rw-r--r--app-emacs/markdown-mode/metadata.xml3
12 files changed, 140 insertions, 1 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 029acb3f9e52..954dc86b8513 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/company-ebuild/Manifest b/app-emacs/company-ebuild/Manifest
new file mode 100644
index 000000000000..793116ed8619
--- /dev/null
+++ b/app-emacs/company-ebuild/Manifest
@@ -0,0 +1,5 @@
+AUX 50company-ebuild-gentoo.el 210 BLAKE2B 669e2366c1c28ad32136578f1f996bfbcd94f654e9b683958f7efb0f542b07f5f580b293b706ab996df07a7e5d86fce2ea0ec4b69b734ac1065508c21d44fd6d SHA512 73814267000a349bbad229d1b172ba61a07733473fd53f0b5a88b6488edf85e95ecad7fb5e145ed423c9c55fa0ed65abec16d99dd5d8cd140407aeb2874508b9
+DIST company-ebuild-0.1.0.tar.gz 10938 BLAKE2B e89e389b49b32057a6acd72cf7a0eb68b10d005824287c112528e3136e7d969e3b678450fc997800d83b3c8f226030b0e2724c63b3ae82d78ad16af49bc10984 SHA512 bc7fec05fbc3600ce6b5111b4e1817bfe04f7185a6a33bf5b83291feb795f47b91f827960b29f844f2627e885a05cc156b755a468e5eb0c314345c869678ea17
+EBUILD company-ebuild-0.1.0.ebuild 611 BLAKE2B fb1fddcb8d3f45bb23339104a23f11544aa461c85f369d36bd273fb2b1e2f16f85d8d214cf04a78d8549bb81add36970ec6f4d14200fad2c5515bb9a4a7db148 SHA512 7a44d9c2d0e1701958e61de247d0c832c5b949273656ebfa454d9e00d4266fa00c41095797a6d1720bc0335c55b3ce5cbdc9750f4f6018a2203675ddb38c515e
+EBUILD company-ebuild-9999.ebuild 611 BLAKE2B fb1fddcb8d3f45bb23339104a23f11544aa461c85f369d36bd273fb2b1e2f16f85d8d214cf04a78d8549bb81add36970ec6f4d14200fad2c5515bb9a4a7db148 SHA512 7a44d9c2d0e1701958e61de247d0c832c5b949273656ebfa454d9e00d4266fa00c41095797a6d1720bc0335c55b3ce5cbdc9750f4f6018a2203675ddb38c515e
+MISC metadata.xml 451 BLAKE2B 85cf2b33444f33f2dee8a0ccdfff3f83de7ab15d3233e0264dbceddb68382cdd551a6dcc691d71f52fbf8a3e7d1a1d041bab9b3dae0c91e81f7d7c3de8f3e2bc SHA512 4886219382c419a94a07041a0e4d0ed6622c45a0371cd0c70a912d391ee29db1a6e730c1134b8493e5edb299646f35df8eb799cfa311f3927256dba2cb345b55
diff --git a/app-emacs/company-ebuild/company-ebuild-0.1.0.ebuild b/app-emacs/company-ebuild/company-ebuild-0.1.0.ebuild
new file mode 100644
index 000000000000..febf2b249a55
--- /dev/null
+++ b/app-emacs/company-ebuild/company-ebuild-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Company backend for editing Ebuild files"
+HOMEPAGE="https://gitweb.gentoo.org/proj/company-ebuild.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/company-mode
+ app-emacs/ebuild-mode
+"
+BDEPEND="${RDEPEND}"
diff --git a/app-emacs/company-ebuild/company-ebuild-9999.ebuild b/app-emacs/company-ebuild/company-ebuild-9999.ebuild
new file mode 100644
index 000000000000..febf2b249a55
--- /dev/null
+++ b/app-emacs/company-ebuild/company-ebuild-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Company backend for editing Ebuild files"
+HOMEPAGE="https://gitweb.gentoo.org/proj/company-ebuild.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/company-mode
+ app-emacs/ebuild-mode
+"
+BDEPEND="${RDEPEND}"
diff --git a/app-emacs/company-ebuild/files/50company-ebuild-gentoo.el b/app-emacs/company-ebuild/files/50company-ebuild-gentoo.el
new file mode 100644
index 000000000000..45da4c86348f
--- /dev/null
+++ b/app-emacs/company-ebuild/files/50company-ebuild-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-ebuild "company-ebuild"
+ "Company backend for editing Ebuild files." t)
+(autoload 'company-ebuild-setup "company-ebuild"
+ "Setup for Company-Ebuild.")
diff --git a/app-emacs/company-ebuild/metadata.xml b/app-emacs/company-ebuild/metadata.xml
new file mode 100644
index 000000000000..243979d0ba2e
--- /dev/null
+++ b/app-emacs/company-ebuild/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <maintainer status="active">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/exec-path-from-shell/Manifest b/app-emacs/exec-path-from-shell/Manifest
new file mode 100644
index 000000000000..f07d0e5a6436
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/Manifest
@@ -0,0 +1,4 @@
+AUX 50exec-path-from-shell-gentoo.el 84 BLAKE2B 0f3b62567ac7e3d501fe9d728cf380383f789f4c3107044747f2cfecd682f71404a49b4afa145f18e5dddc6f41247035fe72e01d6f3b362586017fdedc216c8e SHA512 42f18f03262f302c8ab28b0db1f285ab27caa19cf9acc4df4b289bd24d0e379e847022f59d5ac627ea3ebe1ba1c3f0a55ecba94d3b7f6825bcfee324983e216f
+DIST exec-path-from-shell-1.12.tar.gz 17125 BLAKE2B 01440c4f484fa2e584c40961cc3a0199a812072b3a41c78833a43bd57105e677077f902ef40dbb68eeaaa84fc511d9e02d7fabdbd7c86a0bc57e1ba88aaa6888 SHA512 62f0f89f542cbf0edaf163c1dfd4fac8bb532898f8eb5a9e068a991eaddb5e6ecb1813fc76252dc2d48b42b9ab602082f612d241613002b1a37b4f7d5f5d4f3c
+EBUILD exec-path-from-shell-1.12.ebuild 528 BLAKE2B e9885d2c3809df21485e8969e6961f17fee9ff76448ba5a5500ffe4094c03fae37888133be7f781ddb2934a5b9977c98abb1147cdc358d291988cbe5e385dc37 SHA512 0f760babb7aaed92de44f8d1e897fb56865b1c1b53ccd30d9c408e7d6e8ea22cbb4d45c717d6d7e962b8d958765e1e50e4aee1c630d0d912f4bc23dc555fc5ac
+MISC metadata.xml 817 BLAKE2B 013b0baf63e956f1c9bfa234348c4ec80888321257fda7569324033c1c48418b979972d48d8bbcfb83d75cfb44fae9a0cd484bd1e7e7a65c7fec58542aeccd7e SHA512 78d256c67f5e15e1895e13ab57fbe8d80897184f2aa04698df4a4de60ab0da5dbbb59c65f3696e2e548456eee249550bffdda45025abd3844c0fbb6c6886cb02
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
new file mode 100644
index 000000000000..f21f1c54ffd5
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
new file mode 100644
index 000000000000..6fa79c9aefcf
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "exec-path-from-shell-autoloads" nil t)
diff --git a/app-emacs/exec-path-from-shell/metadata.xml b/app-emacs/exec-path-from-shell/metadata.xml
new file mode 100644
index 000000000000..053f64ad6502
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This library allows the user to set Emacs' `exec-path' and $PATH from the
+ shell path, so that `shell-command', `compile' and the like work as
+ expected. It also allows other environment variables to be retrieved from
+ the shell, so that Emacs will see the same values you get in a terminal.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/purcell/exec-path-from-shell/issues/</bugs-to>
+ <remote-id type="github">purcell/exec-path-from-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/markdown-mode/Manifest b/app-emacs/markdown-mode/Manifest
index 58b94edd44e1..9de8242c29e5 100644
--- a/app-emacs/markdown-mode/Manifest
+++ b/app-emacs/markdown-mode/Manifest
@@ -6,4 +6,4 @@ DIST markdown-mode-2.4.tar.gz 211229 BLAKE2B 49a369d1b418634449cdac3103e1b107b5d
DIST markdown-mode-2.5.tar.gz 218329 BLAKE2B ea4f3e316383951c00e6a68e388db228567b7a06ac87bb268f28c026a8518e9a8516f27d137c79c24727bd71c785a6e9f1217d160e472abc7bdba2c5bda17f16 SHA512 6bb4d79a5a4c3d3891fc8be4d357fa6dccae9f3eeb8f6c04f840da6cfe6875090ebcc0b1a74961e2a4ac1a59389781fa37ef2420383019983705c2cc66db5b8e
EBUILD markdown-mode-2.4-r1.ebuild 710 BLAKE2B efa7775bb49d27324bb5804a82556888b3a854a86409ff55602f4c26fd4df03fef392ac1799a8974c8f63d9a5a4fcc97aaf6931d3396131bae154ca613ecdfc0 SHA512 6363f1f2fed4c3cbfc3491b421f35a1d4a10f6bfdfe68ba1ff1cda6b3e2d78efc67eca184e7db7fd605fe8942dc912ccf0b6774c57734b7961850dd6310e06e0
EBUILD markdown-mode-2.5-r1.ebuild 808 BLAKE2B c3e65ef9729b2ade49276d06348a742d8251ee1b3a9d526ff7da85af7bb89c6281216436e4c205b2084a1b67fe94fb28973b8fd72b06f40926b753e34d12c4bb SHA512 126ed238c86a4a260389916a6dd0b6fda1a850d3628e899947be5c36f1bc6c0cc59c4e594d0e49cebc9b97c09523fb68116ee73976fdc5c83cdb026e41e6c607
-MISC metadata.xml 391 BLAKE2B 7896c25acf1c0a3665565c068ac5cfea1cee77fda0444553c8f08ce45f6c58b967e5dd882de62596847b8714ad25e4454106a74c91c09a28a1985d0d7d3d0773 SHA512 a023ae9b9c85478974d4512e32b9308013a9fa8646a9aad443d4efe84055b57a2c628cf67f4f63073326dbe5e65ad3c4ef1a21963cc7b6d8b61b5d19ff95bf07
+MISC metadata.xml 477 BLAKE2B 4bb74aa04027605e0346a684271091a4d5f11929eab118dd7f5ed0f4292de563903cfae69242a459c8ba51f99135ffa09e021238478e9c6b38bee2e6cf52f882 SHA512 b3be952d7a6e47c5957ee6c7342eef5cfd8ad39d0d9dd0920797fccca36525b4f60dd621bcb4587e0ab63e64c067c7a8e97f498d84b3b8370595ec817fc07903
diff --git a/app-emacs/markdown-mode/metadata.xml b/app-emacs/markdown-mode/metadata.xml
index da6f1023683d..32cca32a7253 100644
--- a/app-emacs/markdown-mode/metadata.xml
+++ b/app-emacs/markdown-mode/metadata.xml
@@ -10,4 +10,7 @@
<name>Gentoo GNU Emacs project</name>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">rblevin/markdown-mode</remote-id>
+ </upstream>
</pkgmetadata>