summaryrefslogtreecommitdiff
path: root/app-emacs/swiper/swiper-0.13.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/swiper/swiper-0.13.4.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/swiper/swiper-0.13.4.ebuild')
-rw-r--r--app-emacs/swiper/swiper-0.13.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/swiper/swiper-0.13.4.ebuild b/app-emacs/swiper/swiper-0.13.4.ebuild
new file mode 100644
index 000000000000..2f7a22c9eec8
--- /dev/null
+++ b/app-emacs/swiper/swiper-0.13.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Alternative to isearch that uses ivy to show overview of all matches"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND=">=app-emacs/ivy-${PV}"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}