summaryrefslogtreecommitdiff
path: root/app-emacs/swiper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/swiper
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/swiper')
-rw-r--r--app-emacs/swiper/Manifest4
-rw-r--r--app-emacs/swiper/files/50swiper-gentoo.el3
-rw-r--r--app-emacs/swiper/metadata.xml15
-rw-r--r--app-emacs/swiper/swiper-0.13.4.ebuild31
4 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/swiper/Manifest b/app-emacs/swiper/Manifest
new file mode 100644
index 000000000000..3cfc2747761f
--- /dev/null
+++ b/app-emacs/swiper/Manifest
@@ -0,0 +1,4 @@
+AUX 50swiper-gentoo.el 108 BLAKE2B fae1fd6258927f672a77b42eb6c826fa246d77e6ce5984c923d272001a6e7f4b523c47fcdec7103845e9705b43cea7e9a91904f6ef0f56fae4de8aa507d57d75 SHA512 1fab726ea0f7288a3f8daee32f2b70f4ca59de0e31144bc88c405a3418f342eb56d96c09754b118831aa33c55e64db8ee9e0df18821d20c1bbf2df4a4034142f
+DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
+EBUILD swiper-0.13.4.ebuild 714 BLAKE2B 19c63ae56138b0fcff5a0d410fdbafbf8825a78723c7826100f833c0ba5c1735b446d9cc201fb5a1cf4475aafaa04d7c60c3149161d0d14a4aec80383459dcb6 SHA512 638c3f0c867abf74145bac09b092558983b0f6e1669c538e2c73b44eaafbe83ab324a0ed34a8538cc12c1176654af76f88eee701b03e6c8c2cd7b292a9157523
+MISC metadata.xml 571 BLAKE2B 26ca5a5dfb1bc67ad37086ddc2c2e5976d1b4c763789a27ee83fb08c4a106a21c33b4c9632a3f2858a6b6249c8c49da3e2eafa7efc5267b655c0c9b2066598e2 SHA512 1879881be5eaeb2a6bac023fd06476a2ccbd25909f7c2f722b4af3680db44b4d3a959e1ac864e86580813a0bc68a2120d936f1c2efd67a6738ee8d83a5adb6f4
diff --git a/app-emacs/swiper/files/50swiper-gentoo.el b/app-emacs/swiper/files/50swiper-gentoo.el
new file mode 100644
index 000000000000..321a3b779ff1
--- /dev/null
+++ b/app-emacs/swiper/files/50swiper-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'swiper "swiper"
+ "`isearch-forward' with an overview." t)
diff --git a/app-emacs/swiper/metadata.xml b/app-emacs/swiper/metadata.xml
new file mode 100644
index 000000000000..37581bba4db7
--- /dev/null
+++ b/app-emacs/swiper/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/abo-abo/swiper/master/doc/Changelog.org</changelog>
+ <bugs-to>https://github.com/abo-abo/swiper/issues/</bugs-to>
+ <remote-id type="github">abo-abo/swiper</remote-id>
+ <doc lang="en">https://oremacs.com/swiper/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/swiper/swiper-0.13.4.ebuild b/app-emacs/swiper/swiper-0.13.4.ebuild
new file mode 100644
index 000000000000..2f7a22c9eec8
--- /dev/null
+++ b/app-emacs/swiper/swiper-0.13.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Alternative to isearch that uses ivy to show overview of all matches"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND=">=app-emacs/ivy-${PV}"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}