summaryrefslogtreecommitdiff
path: root/app-emacs/string-inflection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
commitf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (patch)
treee16b2f573ffa54d21accbf0dfc3647b47b0578c8 /app-emacs/string-inflection
parente9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (diff)
gentoo auto-resync : 10:08:2022 - 20:18:34
Diffstat (limited to 'app-emacs/string-inflection')
-rw-r--r--app-emacs/string-inflection/Manifest4
-rw-r--r--app-emacs/string-inflection/files/50string-inflection-gentoo.el2
-rw-r--r--app-emacs/string-inflection/metadata.xml18
-rw-r--r--app-emacs/string-inflection/string-inflection-1.0.16.ebuild27
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/string-inflection/Manifest b/app-emacs/string-inflection/Manifest
new file mode 100644
index 000000000000..12d7a03960e4
--- /dev/null
+++ b/app-emacs/string-inflection/Manifest
@@ -0,0 +1,4 @@
+AUX 50string-inflection-gentoo.el 81 BLAKE2B a8d271963c8ee584ed50ab57b0797f2406728f1ba4fcdcc705a4cc134b307d0a66dd61d0dc9893377a7dd6ebc582312388ec831e9eb90c3637207caf73eec2ca SHA512 4715c7f6502d55ba7f821a8cf8ce1b89edc021808c1566cfdda6ea04fafd1988f7088d9d80e889e654c509c73e1547422cf3c0ad949d90a4038a044c47a56115
+DIST string-inflection-1.0.16.tar.gz 6238 BLAKE2B 2a8db2786f9a744329e6e298308a5bec00e6872ed350ab867ff2d2d5176cbb1532d3dec5e09573228808fd5ba3e3214cda063cf01cd52f862043718e8e664bec SHA512 7bd575c02e1917d9f52f49c4409150dbc9d097968304e687eb1145520ed88dee0bc359bbc85883dd1c167e8918440c91d1f362983f0a35f99feff61c85a08ca8
+EBUILD string-inflection-1.0.16.ebuild 663 BLAKE2B 6572ed3038a751e2256eb59ede2a873913a3c404d829e5b8a38b1ea3f3c243008887c2e610e9c72958e37a5c5d1ac5ce55cb5687feeebf9d437daffb169b0361 SHA512 2a4b2e9493d980ba21beceb59262825a158a0832975c3d5164d90a12a80000e6ca67efae2ce2d5a50ed1a4384695e8dbf3c238718fde67fe8e26873afeafe8d4
+MISC metadata.xml 713 BLAKE2B b11d272fc2fb866eabc353bf90a5a22c19e40637150709406985838d2b05cbac17603c54b60bed771e435b3155448735b0dbbae3ccc2a32dc2a92146f64e0fe9 SHA512 a1f00997455092ba5d2014419da0614bbb1801870573fe28c71106595e9c2190230c4f1109b7d6c6551d09e330278b59e3da1cb93bcf2a9b42a4f3ae85a66aab
diff --git a/app-emacs/string-inflection/files/50string-inflection-gentoo.el b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
new file mode 100644
index 000000000000..df8f2cee5137
--- /dev/null
+++ b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "string-inflection-autoloads" nil t)
diff --git a/app-emacs/string-inflection/metadata.xml b/app-emacs/string-inflection/metadata.xml
new file mode 100644
index 000000000000..cd4c3ed5c6ab
--- /dev/null
+++ b/app-emacs/string-inflection/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This Emacs package provides convenient methods for manipulating the naming
+ style of a symbol. It supports different naming conventions such as: camel
+ case, Pascal case, all upper case, lower case separated by underscore.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/akicho8/string-inflection/issues/</bugs-to>
+ <remote-id type="github">akicho8/string-inflection</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/string-inflection/string-inflection-1.0.16.ebuild b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
new file mode 100644
index 000000000000..74a4f359e8e7
--- /dev/null
+++ b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Convert symbol names between different naming conventions"
+HOMEPAGE="https://github.com/akicho8/string-inflection/"
+SRC_URI="https://github.com/akicho8/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org HISTORY.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el || die
+}