summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
commitf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (patch)
treee16b2f573ffa54d21accbf0dfc3647b47b0578c8 /app-emacs
parente9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (diff)
gentoo auto-resync : 10:08:2022 - 20:18:34
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin58982 -> 59636 bytes
-rw-r--r--app-emacs/citar/Manifest4
-rw-r--r--app-emacs/citar/citar-1.0.ebuild43
-rw-r--r--app-emacs/citar/files/50citar-gentoo.el2
-rw-r--r--app-emacs/citar/metadata.xml23
-rw-r--r--app-emacs/citeproc-el/Manifest4
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild47
-rw-r--r--app-emacs/citeproc-el/files/50citeproc-el-gentoo.el1
-rw-r--r--app-emacs/citeproc-el/metadata.xml27
-rw-r--r--app-emacs/string-inflection/Manifest4
-rw-r--r--app-emacs/string-inflection/files/50string-inflection-gentoo.el2
-rw-r--r--app-emacs/string-inflection/metadata.xml18
-rw-r--r--app-emacs/string-inflection/string-inflection-1.0.16.ebuild27
-rw-r--r--app-emacs/yaml/Manifest4
-rw-r--r--app-emacs/yaml/files/50yaml-gentoo.el1
-rw-r--r--app-emacs/yaml/metadata.xml18
-rw-r--r--app-emacs/yaml/yaml-0.5.1.ebuild25
17 files changed, 250 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index bdb6d74deeb3..0d6f6f79ab81 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
new file mode 100644
index 000000000000..49ff9b18b3ba
--- /dev/null
+++ b/app-emacs/citar/Manifest
@@ -0,0 +1,4 @@
+AUX 50citar-gentoo.el 69 BLAKE2B 4852ed7422e341e92f938dceedc3d6f0d0fdf8f955ef93021286d9d10e7c3a5d726175e2e79d34ca67f6815d7d6e0445ca2c9a80a2a6690daf4bda49d9972f96 SHA512 0afe62329cd2dc6ea548bbc28aa3c7fea86fb2a20febc91528ba994c77edf08fd72dcf1a0c417dcd4db75b4a6b8e237ade2257130ff3887499377b8f77fefc46
+DIST citar-1.0.tar.gz 1339812 BLAKE2B 2093cc820199219ec70f99a746c630f2b8e6b4d464b1457d7b7db1c5c953138e7dd5ac55e21b13e7417dd0a764b6f1caaf400af353ecce9fb7e1bc578f570b0d SHA512 7f02a4e41a927c2c7c625189fa38caea8f0fc5616dd3487a93f71a373d1e4a124dd1cc520778a1ff2fa6dd7c3b619b539e3b0e47cb9caf7edd16e27e9d739585
+EBUILD citar-1.0.ebuild 979 BLAKE2B 8b40e7b2c88ea5b739db50ffd588be12720330a89c84a11c2e0092fab7c08bc8c411e04e476df97867a7fd0ba59bee8829519a99fc2856c70ecbca7da8c2a29a SHA512 192a72c0a645dde0fabd681769f1dfa1eb9cf5f2cc91a996c7f52f837ef014543b2d2f299b35dcf3ee5c696da66f3fa63fc84caa64692d599293f95b67424bf0
+MISC metadata.xml 1034 BLAKE2B 10d658566f58e3a91deab1c4d2035bcd25ee216777aa105b1e8c8853ab103add779f0f439e706496b2468a3fcb8490320ccb454d90c2e70b5b8bbe9f218773e4 SHA512 4b81115dfccc471987c63876c0b282875fe95c5738f69dfdf7a6300c37998102f2fdda829d14938871bd857fbb5d145e6c62b5b4be40b532f46245256d0be259
diff --git a/app-emacs/citar/citar-1.0.ebuild b/app-emacs/citar/citar-1.0.ebuild
new file mode 100644
index 000000000000..0f6a51de1eb0
--- /dev/null
+++ b/app-emacs/citar/citar-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.org CONTRIBUTING.org README.org images )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citar/files/50citar-gentoo.el b/app-emacs/citar/files/50citar-gentoo.el
new file mode 100644
index 000000000000..6243866c44c2
--- /dev/null
+++ b/app-emacs/citar/files/50citar-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "citar-autoloads" nil t)
diff --git a/app-emacs/citar/metadata.xml b/app-emacs/citar/metadata.xml
new file mode 100644
index 000000000000..2ba5ec6831b5
--- /dev/null
+++ b/app-emacs/citar/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs package to quickly find and act on bibliographic references, and edit
+ org, markdown, and latex academic documents. This package provides a
+ completing-read front-end to browse and act on BibTeX, BibLaTeX, and CSL
+ JSON bibliographic data, and LaTeX, markdown, and org-cite editing support.
+ When used with vertico, embark, and marginalia, it provides similar
+ functionality to helm-bibtex and ivy-bibtex: quick filtering and selecting
+ of bibliographic entries from the minibuffer, and the option to run
+ different commands against them.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/emacs-citar/citar/issues/</bugs-to>
+ <remote-id type="github">emacs-citar/citar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
new file mode 100644
index 000000000000..8c0b587e41fc
--- /dev/null
+++ b/app-emacs/citeproc-el/Manifest
@@ -0,0 +1,4 @@
+AUX 50citeproc-el-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST citeproc-el-0.9.1.tar.gz 108702 BLAKE2B 409548f50baa37c03906d3435569b8f75d8f0238b2d463e22ab0428a0536c6b12e2bf723a8fc4684fae17b31a9d46121d0ebcfd3cd03ada5b0838c8f0e042106 SHA512 6eab58576b4f851f44b45e444ee43a9022651dd322efa77b6162db0906a8cace70458b0a1431ed3d995d480d38944bafc13e76e04e5a310e8c14ffc28888953f
+EBUILD citeproc-el-0.9.1.ebuild 909 BLAKE2B 6416b809b0f5cb6fa84b9f092103e4892f73720275052209604fec5aca036251929a5cedc99feec206f8199859c9c8883fd8ad6e9ae52023e968fde48d8468ac SHA512 0796d18c86de02a2bb137baecce1fd9a65eb20fa46e8d9cefea9d9560da51e1f5f0dfa7de2e327769ec5b076881f2ee37fbda53d4c6a8ada5f8ea2488c3a4e2f
+MISC metadata.xml 1335 BLAKE2B 100bfe27f5d296a91fa300faa044dd80ba7762e53468b9f4c62c1ffaf23cfbcea7c611451f1ec82385d29d8a0400812ac536c302ae6f4b615bf25583d98c8b8b SHA512 2e9ce67c3e10f25113fe65a9307139b1e493ecb2b6cf15c34c5b4659279361fba04b5830cc20fb7a2818a290067236811754ca92607c8d991ea505657dad7570
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
new file mode 100644
index 000000000000..b59dcf28c0e8
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/citeproc-el/metadata.xml b/app-emacs/citeproc-el/metadata.xml
new file mode 100644
index 000000000000..33a57a1b947e
--- /dev/null
+++ b/app-emacs/citeproc-el/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ citeproc-el is an Emacs Lisp library for rendering citations and
+ bibliographies in styles described in the Citation Style Language (CSL), an
+ XML-based, open format to describe the formatting of bibliographic
+ references (see http://citationstyles.org/ for further information on CSL).
+ The library implements most of the CSL 1.0.2 specification, including such
+ features as citation disambiguation, cite collapsing and subsequent author
+ substitution, and passes more than 70% of the tests in the CSL Test Suite.
+ In addition to the standard CSL-JSON data format, citeproc-el has
+ rudimentary support for reading bibliographic data from BibTeX, biblatex
+ and org-bibtex bibliographies and can produce output in several formats
+ including HTML and org-mode markup (see Supported output formats for the
+ full list).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/andras-simonyi/citeproc-el/issues/</bugs-to>
+ <remote-id type="github">andras-simonyi/citeproc-el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/string-inflection/Manifest b/app-emacs/string-inflection/Manifest
new file mode 100644
index 000000000000..12d7a03960e4
--- /dev/null
+++ b/app-emacs/string-inflection/Manifest
@@ -0,0 +1,4 @@
+AUX 50string-inflection-gentoo.el 81 BLAKE2B a8d271963c8ee584ed50ab57b0797f2406728f1ba4fcdcc705a4cc134b307d0a66dd61d0dc9893377a7dd6ebc582312388ec831e9eb90c3637207caf73eec2ca SHA512 4715c7f6502d55ba7f821a8cf8ce1b89edc021808c1566cfdda6ea04fafd1988f7088d9d80e889e654c509c73e1547422cf3c0ad949d90a4038a044c47a56115
+DIST string-inflection-1.0.16.tar.gz 6238 BLAKE2B 2a8db2786f9a744329e6e298308a5bec00e6872ed350ab867ff2d2d5176cbb1532d3dec5e09573228808fd5ba3e3214cda063cf01cd52f862043718e8e664bec SHA512 7bd575c02e1917d9f52f49c4409150dbc9d097968304e687eb1145520ed88dee0bc359bbc85883dd1c167e8918440c91d1f362983f0a35f99feff61c85a08ca8
+EBUILD string-inflection-1.0.16.ebuild 663 BLAKE2B 6572ed3038a751e2256eb59ede2a873913a3c404d829e5b8a38b1ea3f3c243008887c2e610e9c72958e37a5c5d1ac5ce55cb5687feeebf9d437daffb169b0361 SHA512 2a4b2e9493d980ba21beceb59262825a158a0832975c3d5164d90a12a80000e6ca67efae2ce2d5a50ed1a4384695e8dbf3c238718fde67fe8e26873afeafe8d4
+MISC metadata.xml 713 BLAKE2B b11d272fc2fb866eabc353bf90a5a22c19e40637150709406985838d2b05cbac17603c54b60bed771e435b3155448735b0dbbae3ccc2a32dc2a92146f64e0fe9 SHA512 a1f00997455092ba5d2014419da0614bbb1801870573fe28c71106595e9c2190230c4f1109b7d6c6551d09e330278b59e3da1cb93bcf2a9b42a4f3ae85a66aab
diff --git a/app-emacs/string-inflection/files/50string-inflection-gentoo.el b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
new file mode 100644
index 000000000000..df8f2cee5137
--- /dev/null
+++ b/app-emacs/string-inflection/files/50string-inflection-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "string-inflection-autoloads" nil t)
diff --git a/app-emacs/string-inflection/metadata.xml b/app-emacs/string-inflection/metadata.xml
new file mode 100644
index 000000000000..cd4c3ed5c6ab
--- /dev/null
+++ b/app-emacs/string-inflection/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This Emacs package provides convenient methods for manipulating the naming
+ style of a symbol. It supports different naming conventions such as: camel
+ case, Pascal case, all upper case, lower case separated by underscore.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/akicho8/string-inflection/issues/</bugs-to>
+ <remote-id type="github">akicho8/string-inflection</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/string-inflection/string-inflection-1.0.16.ebuild b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
new file mode 100644
index 000000000000..74a4f359e8e7
--- /dev/null
+++ b/app-emacs/string-inflection/string-inflection-1.0.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Convert symbol names between different naming conventions"
+HOMEPAGE="https://github.com/akicho8/string-inflection/"
+SRC_URI="https://github.com/akicho8/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org HISTORY.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el || die
+}
diff --git a/app-emacs/yaml/Manifest b/app-emacs/yaml/Manifest
new file mode 100644
index 000000000000..eebf2c3d7883
--- /dev/null
+++ b/app-emacs/yaml/Manifest
@@ -0,0 +1,4 @@
+AUX 50yaml-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST yaml-0.5.1.tar.gz 44335 BLAKE2B dbcaf29d5d0a18e167cf0fd43d5ea0536d3879ed8bc924930c06aa1eedb2c268f91fd2d0c8981ab81f928db82148ad7fbc01a5926b3dd4645ec57cc78bac7256 SHA512 4ed2dc26a87137deb2d06cffac7c9b0748f66a9b05d91e33022da0edee0966b94ac2dfdb5a181628357dd3714ac55cfb48b1a35f9f6352c01d745a1d69131381
+EBUILD yaml-0.5.1.ebuild 573 BLAKE2B b25bbdf7655812861b9f354c2ad0bbc5e559dcb460f0d5472a314d30fe973d0fab51dae5e19129197e57d7453acc62c69290d7f0f1bd4a927a4d1950ae43cfaf SHA512 a114ebd698d3f955e250947d15ec2ea7424abef1bd6721d3200b93ae6d3d82e92a61eaf3262c509b36c8484e73151b87c0d2dba7291ab94b162d613f46a481b3
+MISC metadata.xml 616 BLAKE2B e28c7b7774635055616362ec847585f91e12a8a92832e51cf8c13dee70ce35273b255257b213804ff5d7ae5733718fc3194f97f1307e45c3dd439be144c82dd0 SHA512 7035a36f53cd4c08a274b88d216fbad3c3fd5579e0c10f38158a5128c61d7feea30800101dbf71c5baa03a3a1f2ec8d61f343a1fec21a067a919cbd146835d77
diff --git a/app-emacs/yaml/files/50yaml-gentoo.el b/app-emacs/yaml/files/50yaml-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/yaml/files/50yaml-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/yaml/metadata.xml b/app-emacs/yaml/metadata.xml
new file mode 100644
index 000000000000..ebb91ed4f6fa
--- /dev/null
+++ b/app-emacs/yaml/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ yaml.el is a YAML parser written in Emacs List without any external
+ dependencies. It provides an interface similar to the Emacs JSON parsing
+ utility.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/zkry/yaml.el/issues/</bugs-to>
+ <remote-id type="github">zkry/yaml.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/yaml/yaml-0.5.1.ebuild b/app-emacs/yaml/yaml-0.5.1.ebuild
new file mode 100644
index 000000000000..7e951ead7442
--- /dev/null
+++ b/app-emacs/yaml/yaml-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="YAML parser in Emacs Lisp"
+HOMEPAGE="https://github.com/zkry/yaml.el/"
+SRC_URI="https://github.com/zkry/yaml.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/yaml.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -l yaml-tests.el || die
+}