summaryrefslogtreecommitdiff
path: root/app-emacs/shut-up/shut-up-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/shut-up/shut-up-0.3.3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/shut-up/shut-up-0.3.3.ebuild')
-rw-r--r--app-emacs/shut-up/shut-up-0.3.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/shut-up/shut-up-0.3.3.ebuild b/app-emacs/shut-up/shut-up-0.3.3.ebuild
new file mode 100644
index 000000000000..f5a6d10ba523
--- /dev/null
+++ b/app-emacs/shut-up/shut-up-0.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Reduce Emacs output of messages"
+HOMEPAGE="https://github.com/cask/shut-up/"
+SRC_URI="https://github.com/cask/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/f
+ app-emacs/s
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}