summaryrefslogtreecommitdiff
path: root/app-emacs/shut-up
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/shut-up
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/shut-up')
-rw-r--r--app-emacs/shut-up/Manifest4
-rw-r--r--app-emacs/shut-up/files/50shut-up-gentoo.el1
-rw-r--r--app-emacs/shut-up/metadata.xml13
-rw-r--r--app-emacs/shut-up/shut-up-0.3.3.ebuild33
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/shut-up/Manifest b/app-emacs/shut-up/Manifest
new file mode 100644
index 000000000000..e15d74783392
--- /dev/null
+++ b/app-emacs/shut-up/Manifest
@@ -0,0 +1,4 @@
+AUX 50shut-up-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST shut-up-0.3.3.tar.gz 4479 BLAKE2B 0cb9ee028386ceb9b80385a6893c203481a79619f8780c641ca76a8878bece3944973ba78a41e1a554d4c9402ec2227d1234a9b6862b01d489dba30db021b731 SHA512 b14110022bd1512985fe40194c419f06cc8f5f6c819f02e681a89c2f80a32140e20eea6e3bb659b1abee85021b01bdc0b48d3ff12d6fac6072635fbdcb808484
+EBUILD shut-up-0.3.3.ebuild 636 BLAKE2B b1408c354c9daa200db0a654a5845e14faa9a324dcddf99c73d713072e5607137a628c01baebe42c82e01bdeffd840394c79bde1dc7c0e12b37bf04b66a3b6fa SHA512 83e48e7cc6d633c79eb9109f056dd2e7271e770bfbda346e925275b60f4e0371a7cda4bc7f37d30080d33ffa761dc47cedd9b9500244c10d426d4c937c0e010e
+MISC metadata.xml 413 BLAKE2B 2d07d61a75f66e64e2a0b1fd32771e84572417daaca31b6c27f5da0ec2d1a4db44668aed9ad2dfe82d5eafdd0a3f45d9f3e3dd3907c059ff00ee5bf4e9620455 SHA512 9f5d7149c0e130afeea13ed28ae9354d1f900db5a884f1772c37ebef2bb09a39b193eaf89d0033697507c5f9a318ab204b8c2711767415306543a02813b968f7
diff --git a/app-emacs/shut-up/files/50shut-up-gentoo.el b/app-emacs/shut-up/files/50shut-up-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/shut-up/files/50shut-up-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/shut-up/metadata.xml b/app-emacs/shut-up/metadata.xml
new file mode 100644
index 000000000000..ed648c38c11b
--- /dev/null
+++ b/app-emacs/shut-up/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/cask/shut-up/issues/</bugs-to>
+ <remote-id type="github">cask/shut-up</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/shut-up/shut-up-0.3.3.ebuild b/app-emacs/shut-up/shut-up-0.3.3.ebuild
new file mode 100644
index 000000000000..f5a6d10ba523
--- /dev/null
+++ b/app-emacs/shut-up/shut-up-0.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Reduce Emacs output of messages"
+HOMEPAGE="https://github.com/cask/shut-up/"
+SRC_URI="https://github.com/cask/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/f
+ app-emacs/s
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l test/${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}