summaryrefslogtreecommitdiff
path: root/app-emacs/sesman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /app-emacs/sesman
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'app-emacs/sesman')
-rw-r--r--app-emacs/sesman/Manifest4
-rw-r--r--app-emacs/sesman/files/50sesman-gentoo.el5
-rw-r--r--app-emacs/sesman/metadata.xml25
-rw-r--r--app-emacs/sesman/sesman-0.3.4.ebuild30
4 files changed, 64 insertions, 0 deletions
diff --git a/app-emacs/sesman/Manifest b/app-emacs/sesman/Manifest
new file mode 100644
index 000000000000..ed017ef5a7fb
--- /dev/null
+++ b/app-emacs/sesman/Manifest
@@ -0,0 +1,4 @@
+AUX 50sesman-gentoo.el 192 BLAKE2B 376a95031b1f289419e2338ef41bd0f151fcb8dd71b7a8ec9443c0d3469b6dae87e2fbf8010c521a60aed6ec39464bfa75fbcebafe204ec4dd016ca39816da01 SHA512 beb977f788b1ee8eaecea5bc45564e6d38fd2f7729486057ae725199efea413661308989da3c5b07551d351b5deacd585963439134953a84e369bd5be6b788ea
+DIST sesman-0.3.4.tar.gz 18256 BLAKE2B 3d7eca5bb5df1778053cf9e37a9d02f16fd98e3c42163c19ae8bf04815ed7e1a7e17b5a050ad5b3f7258764c0a2d71c06de820b6023df100e4a2d3aa263ced2d SHA512 e9478ca4a3cbe1cc357b983c14d94fbe20b95cc8ac1789136700016ce749febcbf3ce28879e9fc02373fbf1a828c0786b35a6e808baf8a607aa34292838a49bf
+EBUILD sesman-0.3.4.ebuild 599 BLAKE2B 0ba7b1026a8f92b190782e1292254a842537eb19f9ceff3c1efa22385a1846cdd312d282ac6b2bc18c9898b7bd3b47ead3c6a518b5ff1f00ec4fc9877553dd74 SHA512 ea054220383d9c0f3e5d6f7579bc2ad427ff1a6936aa0e6c7bfacbea33556d01aee20a5636892979148f26bc64270031933ce83e5d02fdebb6fbf3d035ec7061
+MISC metadata.xml 1208 BLAKE2B fcd066b3967847992b4eaf1ebc066bc7ac4f4620570fcef1ad2d7a724ce6b1d4ca18a76e7ca434a0e46c9ef2f27fb64b3f051fa5ed007a6850d2567376726a58 SHA512 ad399c3de4c8c9b209befa389ca048e63892022e5cbd656cc5633a715047055c2b8455384a90503f9ade3f8ba547363cc9adb4cdb242ac4c049d85b480741b40
diff --git a/app-emacs/sesman/files/50sesman-gentoo.el b/app-emacs/sesman/files/50sesman-gentoo.el
new file mode 100644
index 000000000000..fa3dffc96c2e
--- /dev/null
+++ b/app-emacs/sesman/files/50sesman-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sesman-browser "sesman-browser"
+ "Display an interactive session browser." t)
+(autoload 'sesman-start "sesman"
+ "Start a Sesman session." t)
diff --git a/app-emacs/sesman/metadata.xml b/app-emacs/sesman/metadata.xml
new file mode 100644
index 000000000000..017fcd7db750
--- /dev/null
+++ b/app-emacs/sesman/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Sesman provides facilities for session management and interactive session
+ association with the current contexts (e.g. project, directory, buffers).
+ While sesman can be used to manage arbitrary "sessions", it primary targets
+ the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.) For Emacs based
+ IDEs, session are commonly composed of one or more physical processes
+ (sub-processes, sockets, websockets etc). For example in the current
+ implementation of CIDER a session would be composed of one or more sesman
+ connections (Clojure or ClojureScript). Each CIDER connection consists of
+ user REPL buffer and two sub-processes, one for user eval communication and
+ another for tooling (completion, inspector etc).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/vspinu/sesman/issues/</bugs-to>
+ <remote-id type="github">vspinu/sesman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/sesman/sesman-0.3.4.ebuild b/app-emacs/sesman/sesman-0.3.4.ebuild
new file mode 100644
index 000000000000..2018a07a9f2b
--- /dev/null
+++ b/app-emacs/sesman/sesman-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Generic session manager for Emacs based IDEs"
+HOMEPAGE="https://github.com/vspinu/sesman/"
+SRC_URI="https://github.com/vspinu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l ${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
+
+src_install() {
+ rm sesman-test.el* || die
+
+ elisp_src_install
+}