summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /app-emacs
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin63197 -> 63990 bytes
-rw-r--r--app-emacs/a/Manifest4
-rw-r--r--app-emacs/a/a-1.0.0.ebuild29
-rw-r--r--app-emacs/a/files/50a-gentoo.el1
-rw-r--r--app-emacs/a/metadata.xml17
-rw-r--r--app-emacs/cider/Manifest4
-rw-r--r--app-emacs/cider/cider-1.5.0.ebuild46
-rw-r--r--app-emacs/cider/files/50cider-gentoo.el5
-rw-r--r--app-emacs/cider/metadata.xml21
-rw-r--r--app-emacs/parseclj/Manifest4
-rw-r--r--app-emacs/parseclj/files/50parseclj-gentoo.el1
-rw-r--r--app-emacs/parseclj/metadata.xml18
-rw-r--r--app-emacs/parseclj/parseclj-1.1.0.ebuild28
-rw-r--r--app-emacs/parseedn/Manifest4
-rw-r--r--app-emacs/parseedn/files/50parseedn-gentoo.el1
-rw-r--r--app-emacs/parseedn/metadata.xml21
-rw-r--r--app-emacs/parseedn/parseedn-1.1.0.ebuild33
-rw-r--r--app-emacs/sesman/Manifest4
-rw-r--r--app-emacs/sesman/files/50sesman-gentoo.el5
-rw-r--r--app-emacs/sesman/metadata.xml25
-rw-r--r--app-emacs/sesman/sesman-0.3.4.ebuild30
21 files changed, 301 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 9394f71f4239..579822fa786e 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/a/Manifest b/app-emacs/a/Manifest
new file mode 100644
index 000000000000..c5b0fd24c47b
--- /dev/null
+++ b/app-emacs/a/Manifest
@@ -0,0 +1,4 @@
+AUX 50a-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST a.el-1.0.0.tar.gz 19740 BLAKE2B c5bb72fd206b1b33798c90982f7111f7cd100e6e36580bce267b6d6295a82b536a00cddeed3cf9bf94964b451429769f705358a731cbe5054a2683fc90d4bf14 SHA512 3a795fb2cf613bafabbf2c788dc1edd4dbd26871043a9225f3db61542f1d5c95102355d9223498dc4dbe5aba446e9b8a22437b6e6799c3a0f2ad213bc35b2556
+EBUILD a-1.0.0.ebuild 642 BLAKE2B 649f245dc151eec048bb3dd67fb94678be30aade5733aaff1465e72b929678016cc76d554956d4b59e3665764c33e2dd26dbb5231680b3468a8340220b8e2f2b SHA512 690d58f2d5b7ae05fabbf5ff088c48baee79694ac2f987917c42fcae69ec8b53a799a7f4c2a36e2f3bd6cbc771836f1cb0e9be8160951f57d73b1768fcbcd8cb
+MISC metadata.xml 593 BLAKE2B 58d0e7438e7d43af9b2bc9b998cb80cfc7328988f421bab49fc0147b8edd0d85938dff46fac08e5c123f74d81cbd5e83a13d8de5f65a12f1beb134fc3677ba6e SHA512 9c00a6a7554c7000cff70b36f9cae8da18b6dbedd1b8a9cedd478da2028ecb00bc44567b75f21b79c3e1768aa9b01d4521e7fda6f23edb31610b4919ac5789ac
diff --git a/app-emacs/a/a-1.0.0.ebuild b/app-emacs/a/a-1.0.0.ebuild
new file mode 100644
index 000000000000..a6fe49e7363f
--- /dev/null
+++ b/app-emacs/a/a-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Associative data structure functions for Emacs Lisp"
+HOMEPAGE="https://github.com/plexus/a.el/"
+SRC_URI="https://github.com/plexus/a.el/archive/v${PV}.tar.gz
+ -> a.el-${PV}.tar.gz"
+S="${WORKDIR}"/a.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
diff --git a/app-emacs/a/files/50a-gentoo.el b/app-emacs/a/files/50a-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/a/files/50a-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/a/metadata.xml b/app-emacs/a/metadata.xml
new file mode 100644
index 000000000000..3a987898ee9d
--- /dev/null
+++ b/app-emacs/a/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Emacs Lisp functions for dealing with associative structures in a uniform
+ and functional way. Inspired by Clojure, dash, and seq.el.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/plexus/a.el/issues/</bugs-to>
+ <remote-id type="github">plexus/a.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/cider/Manifest b/app-emacs/cider/Manifest
new file mode 100644
index 000000000000..039966c2cb13
--- /dev/null
+++ b/app-emacs/cider/Manifest
@@ -0,0 +1,4 @@
+AUX 50cider-gentoo.el 213 BLAKE2B 5dfecdc5467e5e359be87197388c33ad5d12f58772755ce41a7c9c43733a3c828f3e6a76a75f9af781e0bc0466f950c673159dbf404afd7f34f4b09105f7f3b3 SHA512 fda3962b2b215456d167453da5269034cae830e8938f10b0b3b5bcd830c3bf623351a13afa6364d4082ed763e3bd42447a4b625d51a7690263c74aae08cac794
+DIST cider-1.5.0.tar.gz 6709101 BLAKE2B 0baf8345201b61e99bb279dc6378dd15052c01f32842f98fd756438a173e45f82a061a853a0a453801c6ebdb0d0bc4a2a199d06c08b2413315568348ae1d8ca4 SHA512 48874bfe54d31b7bf52c56390aab307603b913e6bc717138450a5b49b3ab4c5dea7d031a6f699a8f04d7e43a1dd67fa604c06532d58634949579bf0a6089594b
+EBUILD cider-1.5.0.ebuild 954 BLAKE2B d2a97390650195d3f0a4e45cb0824dd755ecfe49f2230c6335a6c671e5d22a68a95ab8524217eec42bfb5ea7c20b59844ef0a5b5e81a10be5d0e28c400b65982 SHA512 81b67a5dabc8d1163b96229eef88b810b1c61f5d597d049131bedaf9f1eaa99798ec5ddf58e374b4901f8e546e9072bd61bea0b88329c77d3e8b588079f26d17
+MISC metadata.xml 897 BLAKE2B c38773a55001e756ce6c5d2771b51acf6be3c1ecd4bfada0ef506765736c698b3863f83212ed2f321c458f2d9d04402234efc107882afa660beaae6f4cd6aca6 SHA512 ba4bef0aabe4a1e3d2f362268c5dbda1ebd87f89194dd3bde9f19c159873b9e92982a53cfa3b1bf3991c576b527bf02d3d6e5f2c33e15260051adf9fe1a8a307
diff --git a/app-emacs/cider/cider-1.5.0.ebuild b/app-emacs/cider/cider-1.5.0.ebuild
new file mode 100644
index 000000000000..86486ffa8584
--- /dev/null
+++ b/app-emacs/cider/cider-1.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp optfeature
+
+DESCRIPTION="Clojure Interactive Development Environment for GNU Emacs"
+HOMEPAGE="https://github.com/clojure-emacs/cider/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/clojure-mode
+ app-emacs/parseedn
+ app-emacs/queue
+ app-emacs/sesman
+ app-emacs/spinner
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+ELISP_REMOVE="test/${PN}-jar-test.el"
+DOCS=( CHANGELOG.md README.md ROADMAP.md refcard )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ optfeature "Connecting to leiningen REPL" \
+ dev-java/leiningen dev-java/leiningen-bin
+}
diff --git a/app-emacs/cider/files/50cider-gentoo.el b/app-emacs/cider/files/50cider-gentoo.el
new file mode 100644
index 000000000000..298d184202ef
--- /dev/null
+++ b/app-emacs/cider/files/50cider-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'cider "cider"
+ "Start a connection of any type interactively." t)
+(autoload 'cider-mode "cider-mode"
+ "Minor mode for REPL interaction from a Clojure buffer." t)
diff --git a/app-emacs/cider/metadata.xml b/app-emacs/cider/metadata.xml
new file mode 100644
index 000000000000..acd2ef65fb80
--- /dev/null
+++ b/app-emacs/cider/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ CIDER extends Emacs with support for interactive programming in Clojure.
+ The features are centered around cider-mode, an Emacs minor-mode that
+ complements clojure-mode. While clojure-mode supports editing Clojure
+ source files, cider-mode adds support for interacting with a running
+ Clojure process for compilation, code completion, debugging, definition and
+ documentation lookup, running tests and so on.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/cider/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/cider</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseclj/Manifest b/app-emacs/parseclj/Manifest
new file mode 100644
index 000000000000..bc361e86b52b
--- /dev/null
+++ b/app-emacs/parseclj/Manifest
@@ -0,0 +1,4 @@
+AUX 50parseclj-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST parseclj-1.1.0.tar.gz 37228 BLAKE2B d0e74eeb3a1ea9cec7445f3e2627d8d6287ff476fdff4a1dd9b3f58100621a02fc0f0369b96bd92fa8f43485d8c45ffa0a7d41681dfe71020157ca467325e2b9 SHA512 ef8da1f65d4f873c81a785aae495128dc551b73cc89cda7c8b37ce8be15b7473c6cbcd886d5ea285ae414a05a02109b60a8cd933720f1a4b6a1e63e07ec33cf8
+EBUILD parseclj-1.1.0.ebuild 617 BLAKE2B 55c2293dc12e5627da0047415655310f50bf2f581d72f6c450df27ffb41ce0622f3de90fb68b5721fd6bff2f54e049037b6355242918bca275e8867f8734b97f SHA512 0616f78c68e3383cf350b014bd4d594cedca3fa24a373483f5e8a0a3ded9ca33fd15a49cb14a67a97cdff7d619d6c87cd2d94a272a552274a67b310f83b7d6dd
+MISC metadata.xml 659 BLAKE2B 0228d25161ab040e3d14af307f53239c39da58b5980d1a5bbe4628df1d9559e027a91ed345c696dbc910f75249dabe57a1f518ed74c06d48058a670b0249a35c SHA512 fde89c6cf6f7b41304a1824ec54cfd3293bc197cb7321b89ad9f8009b26f2376f6f62d920fc43d9e0b81851387c38d58e0cef86f3c39984572f642607f5f876e
diff --git a/app-emacs/parseclj/files/50parseclj-gentoo.el b/app-emacs/parseclj/files/50parseclj-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseclj/files/50parseclj-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseclj/metadata.xml b/app-emacs/parseclj/metadata.xml
new file mode 100644
index 000000000000..c7ad27b76ae9
--- /dev/null
+++ b/app-emacs/parseclj/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseclj is an Emacs Lisp library for parsing Clojure code and EDN data. It
+ supports several input and output formats, all powered by the same
+ shift-reduce parser function.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseclj/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseclj</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseclj/parseclj-1.1.0.ebuild b/app-emacs/parseclj/parseclj-1.1.0.ebuild
new file mode 100644
index 000000000000..0adbdc6b45d8
--- /dev/null
+++ b/app-emacs/parseclj/parseclj-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Clojure Parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md DESIGN.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
diff --git a/app-emacs/parseedn/Manifest b/app-emacs/parseedn/Manifest
new file mode 100644
index 000000000000..e2df72aff98f
--- /dev/null
+++ b/app-emacs/parseedn/Manifest
@@ -0,0 +1,4 @@
+AUX 50parseedn-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST parseedn-1.1.0.tar.gz 10455 BLAKE2B 2ffe006f254e34ad31e266ceb365cdc1532c4a4c3aaf2d0bd3e26791de560be5662d292436ad4dc4fb6d931e17a319443032ff4949e5e9e86ccf15d90ddac3b6 SHA512 cd7b2070e15f7ddf8ae9f01424400f04b638765c518ae00b3a07ca55de308d79da5aaafdcb1b58e04bc833ddd7c5842d102ff2a6f63ab8d4f6125dbb84bb375a
+EBUILD parseedn-1.1.0.ebuild 702 BLAKE2B 8dfc5acdd90d6600b75dbef55d8d8fc521558f71b4002d7ed90c51448da02d13ce9172b6fc09a29eb64b3930f2a8464b93ae8c23cd202ea85426139842f9f055 SHA512 515ea5ebab9611dd97e1552956405311f0d02d48e7c6886b00b7c1ed382be81e09bb589358d0fcd0bee4b55f61980342f78e70beb4e13c043f6260e42b334f09
+MISC metadata.xml 935 BLAKE2B 59252290a86d7d03fc9dc71632cad89371d16421cbb3a5347410a25eb65f5f0ced1cb65334769e3e5a6043e6db4456104fccebe4d9aec5f9dd1534b9315d7403 SHA512 86f674633ee4319162836f77aafa94f4fbb50d992716bd66a678ef5db9d4311a7911522fbc6e2ac8351f7c075ba7f49b08e90d4e1a862a091a7790de2b627918
diff --git a/app-emacs/parseedn/files/50parseedn-gentoo.el b/app-emacs/parseedn/files/50parseedn-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseedn/files/50parseedn-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseedn/metadata.xml b/app-emacs/parseedn/metadata.xml
new file mode 100644
index 000000000000..0df1d0d9b4e9
--- /dev/null
+++ b/app-emacs/parseedn/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseedn is an Emacs Lisp library for parsing EDN data. It uses parseclj's
+ shift-reduce parser internally. EDN and Emacs Lisp have some important
+ differences that make translation from one to the other not transparent
+ (think representing an EDN map into Elisp, or being able to differentiate
+ between false and nil in Elisp). Because of this, parseedn takes certain
+ decisions when parsing and transforming EDN data into Elisp data types.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseedn/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseedn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseedn/parseedn-1.1.0.ebuild b/app-emacs/parseedn/parseedn-1.1.0.ebuild
new file mode 100644
index 000000000000..092ada16796a
--- /dev/null
+++ b/app-emacs/parseedn/parseedn-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="EDN parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parseclj"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
diff --git a/app-emacs/sesman/Manifest b/app-emacs/sesman/Manifest
new file mode 100644
index 000000000000..ed017ef5a7fb
--- /dev/null
+++ b/app-emacs/sesman/Manifest
@@ -0,0 +1,4 @@
+AUX 50sesman-gentoo.el 192 BLAKE2B 376a95031b1f289419e2338ef41bd0f151fcb8dd71b7a8ec9443c0d3469b6dae87e2fbf8010c521a60aed6ec39464bfa75fbcebafe204ec4dd016ca39816da01 SHA512 beb977f788b1ee8eaecea5bc45564e6d38fd2f7729486057ae725199efea413661308989da3c5b07551d351b5deacd585963439134953a84e369bd5be6b788ea
+DIST sesman-0.3.4.tar.gz 18256 BLAKE2B 3d7eca5bb5df1778053cf9e37a9d02f16fd98e3c42163c19ae8bf04815ed7e1a7e17b5a050ad5b3f7258764c0a2d71c06de820b6023df100e4a2d3aa263ced2d SHA512 e9478ca4a3cbe1cc357b983c14d94fbe20b95cc8ac1789136700016ce749febcbf3ce28879e9fc02373fbf1a828c0786b35a6e808baf8a607aa34292838a49bf
+EBUILD sesman-0.3.4.ebuild 599 BLAKE2B 0ba7b1026a8f92b190782e1292254a842537eb19f9ceff3c1efa22385a1846cdd312d282ac6b2bc18c9898b7bd3b47ead3c6a518b5ff1f00ec4fc9877553dd74 SHA512 ea054220383d9c0f3e5d6f7579bc2ad427ff1a6936aa0e6c7bfacbea33556d01aee20a5636892979148f26bc64270031933ce83e5d02fdebb6fbf3d035ec7061
+MISC metadata.xml 1208 BLAKE2B fcd066b3967847992b4eaf1ebc066bc7ac4f4620570fcef1ad2d7a724ce6b1d4ca18a76e7ca434a0e46c9ef2f27fb64b3f051fa5ed007a6850d2567376726a58 SHA512 ad399c3de4c8c9b209befa389ca048e63892022e5cbd656cc5633a715047055c2b8455384a90503f9ade3f8ba547363cc9adb4cdb242ac4c049d85b480741b40
diff --git a/app-emacs/sesman/files/50sesman-gentoo.el b/app-emacs/sesman/files/50sesman-gentoo.el
new file mode 100644
index 000000000000..fa3dffc96c2e
--- /dev/null
+++ b/app-emacs/sesman/files/50sesman-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sesman-browser "sesman-browser"
+ "Display an interactive session browser." t)
+(autoload 'sesman-start "sesman"
+ "Start a Sesman session." t)
diff --git a/app-emacs/sesman/metadata.xml b/app-emacs/sesman/metadata.xml
new file mode 100644
index 000000000000..017fcd7db750
--- /dev/null
+++ b/app-emacs/sesman/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Sesman provides facilities for session management and interactive session
+ association with the current contexts (e.g. project, directory, buffers).
+ While sesman can be used to manage arbitrary "sessions", it primary targets
+ the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.) For Emacs based
+ IDEs, session are commonly composed of one or more physical processes
+ (sub-processes, sockets, websockets etc). For example in the current
+ implementation of CIDER a session would be composed of one or more sesman
+ connections (Clojure or ClojureScript). Each CIDER connection consists of
+ user REPL buffer and two sub-processes, one for user eval communication and
+ another for tooling (completion, inspector etc).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/vspinu/sesman/issues/</bugs-to>
+ <remote-id type="github">vspinu/sesman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/sesman/sesman-0.3.4.ebuild b/app-emacs/sesman/sesman-0.3.4.ebuild
new file mode 100644
index 000000000000..2018a07a9f2b
--- /dev/null
+++ b/app-emacs/sesman/sesman-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Generic session manager for Emacs based IDEs"
+HOMEPAGE="https://github.com/vspinu/sesman/"
+SRC_URI="https://github.com/vspinu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l ${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
+
+src_install() {
+ rm sesman-test.el* || die
+
+ elisp_src_install
+}