summaryrefslogtreecommitdiff
path: root/app-emacs/parseedn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /app-emacs/parseedn
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'app-emacs/parseedn')
-rw-r--r--app-emacs/parseedn/Manifest4
-rw-r--r--app-emacs/parseedn/files/50parseedn-gentoo.el1
-rw-r--r--app-emacs/parseedn/metadata.xml21
-rw-r--r--app-emacs/parseedn/parseedn-1.1.0.ebuild33
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/parseedn/Manifest b/app-emacs/parseedn/Manifest
new file mode 100644
index 000000000000..e2df72aff98f
--- /dev/null
+++ b/app-emacs/parseedn/Manifest
@@ -0,0 +1,4 @@
+AUX 50parseedn-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST parseedn-1.1.0.tar.gz 10455 BLAKE2B 2ffe006f254e34ad31e266ceb365cdc1532c4a4c3aaf2d0bd3e26791de560be5662d292436ad4dc4fb6d931e17a319443032ff4949e5e9e86ccf15d90ddac3b6 SHA512 cd7b2070e15f7ddf8ae9f01424400f04b638765c518ae00b3a07ca55de308d79da5aaafdcb1b58e04bc833ddd7c5842d102ff2a6f63ab8d4f6125dbb84bb375a
+EBUILD parseedn-1.1.0.ebuild 702 BLAKE2B 8dfc5acdd90d6600b75dbef55d8d8fc521558f71b4002d7ed90c51448da02d13ce9172b6fc09a29eb64b3930f2a8464b93ae8c23cd202ea85426139842f9f055 SHA512 515ea5ebab9611dd97e1552956405311f0d02d48e7c6886b00b7c1ed382be81e09bb589358d0fcd0bee4b55f61980342f78e70beb4e13c043f6260e42b334f09
+MISC metadata.xml 935 BLAKE2B 59252290a86d7d03fc9dc71632cad89371d16421cbb3a5347410a25eb65f5f0ced1cb65334769e3e5a6043e6db4456104fccebe4d9aec5f9dd1534b9315d7403 SHA512 86f674633ee4319162836f77aafa94f4fbb50d992716bd66a678ef5db9d4311a7911522fbc6e2ac8351f7c075ba7f49b08e90d4e1a862a091a7790de2b627918
diff --git a/app-emacs/parseedn/files/50parseedn-gentoo.el b/app-emacs/parseedn/files/50parseedn-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseedn/files/50parseedn-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseedn/metadata.xml b/app-emacs/parseedn/metadata.xml
new file mode 100644
index 000000000000..0df1d0d9b4e9
--- /dev/null
+++ b/app-emacs/parseedn/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseedn is an Emacs Lisp library for parsing EDN data. It uses parseclj's
+ shift-reduce parser internally. EDN and Emacs Lisp have some important
+ differences that make translation from one to the other not transparent
+ (think representing an EDN map into Elisp, or being able to differentiate
+ between false and nil in Elisp). Because of this, parseedn takes certain
+ decisions when parsing and transforming EDN data into Elisp data types.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseedn/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseedn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseedn/parseedn-1.1.0.ebuild b/app-emacs/parseedn/parseedn-1.1.0.ebuild
new file mode 100644
index 000000000000..092ada16796a
--- /dev/null
+++ b/app-emacs/parseedn/parseedn-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="EDN parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/parseclj"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/ert-runner )
+"
+
+ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+DOCS=( CHANGELOG.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}