summaryrefslogtreecommitdiff
path: root/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild')
-rw-r--r--app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
new file mode 100644
index 000000000000..b52af57974bd
--- /dev/null
+++ b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=6c1d63511fb2b3b3f2e342eff6a375d78be6c12c
+NEED_EMACS=25.1
+
+inherit optfeature elisp
+
+DESCRIPTION="Run an inferior Julia REPL in a terminal inside Emacs"
+HOMEPAGE="https://github.com/tpapp/julia-repl/"
+SRC_URI="https://github.com/tpapp/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-emacs/s"
+RDEPEND="
+ ${BDEPEND}
+ app-emacs/julia-mode
+"
+
+DOCS=( CHANGELOG.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-force-compile.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l ert -l ./${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ rm ./${PN}-tests.el || die
+
+ elisp_src_install
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "running Julia inside VTerm" app-emacs/vterm
+}