summaryrefslogtreecommitdiff
path: root/app-emacs/julia-repl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/julia-repl
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/julia-repl')
-rw-r--r--app-emacs/julia-repl/Manifest5
-rw-r--r--app-emacs/julia-repl/files/50julia-repl-gentoo.el4
-rw-r--r--app-emacs/julia-repl/files/julia-repl-force-compile.patch9
-rw-r--r--app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild46
-rw-r--r--app-emacs/julia-repl/metadata.xml23
5 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/julia-repl/Manifest b/app-emacs/julia-repl/Manifest
new file mode 100644
index 000000000000..b8650dabd2ce
--- /dev/null
+++ b/app-emacs/julia-repl/Manifest
@@ -0,0 +1,5 @@
+AUX 50julia-repl-gentoo.el 198 BLAKE2B 0b355f7563dcf226f9b6cf6984e51cc5f2c333a00e31a929972da3afb1c9bbe0de3062837a6c4763cc0edb8488ffa9c34e5adc07bbc7ea55e2be8bf51225255e SHA512 5de7d0b1972eaf4a3e4d43b54774f88cf2d34abfbaf78c018641df6ff3f0b36540bc44300592e5d89052a57988beb81d272d229049f76d82b13475f1aa8b0abd
+AUX julia-repl-force-compile.patch 346 BLAKE2B 5ffe058f6b3c201a0b7cbef373959c71d5ab3e59f62126680681b39ca506cafbe2bb5c559749e7257b632fe479781171a49949f27a2587a5d45caf0307df8195 SHA512 14220f9d62b24f5d9b3d73d705f93f75b7c5056690f7668e163d3bc59b4e9622e9914e0a95e0f9dd114517a2d14ec88303cbe439c4ad8e8129458b6e8d2fc917
+DIST julia-repl-1.3.0_p20220225.tar.gz 183305 BLAKE2B 65b07101008e0548041084f50bec3022789363d8e33c6870382166c2989f56c908a7f7df378d49f55b64479d562594ff14e518a66bd36a907714214521add31f SHA512 12d9445432158c12e857c71683ea39b0bd8a76fa415ebe1d85b682d65b53c456518d88b08f98d900211c04f5d1bf12f50e4ce70ff28d4c4a657b072731968a14
+EBUILD julia-repl-1.3.0_p20220225.ebuild 964 BLAKE2B 66cda15fdf5d18f1a00c3cb927752a1d822d8f61c6e630931bbc1f2bdb8b38ed80d78dd5560f3100dba61434cadbe557be5e29c27f599b3fa3a363f9ec3c8371 SHA512 a5711e2716d99f7fdbbd0e493c45fc43e38727b16c6b82aff3fb439fc7678c4b5a259ab1a3fc5bebaf7e50f22ede0de0c97cb560559e87f20ba814335fe7a798
+MISC metadata.xml 886 BLAKE2B ff4b7b2936dbccb530df87681e54ddc98a703a7a233e8b48c4e1b9c52c78f150dc81c12e8e5aee119d5d8ca43bdec61032118f64981beec60856e1202ab72cae SHA512 7eea298533262ceaf712159f915d971080f84babaccf940365b83a128aaff3df79a0fc2c19736016fc31f35c87f9ca84ec31aa0a61c24dc1a7b0809a1c9d7a89
diff --git a/app-emacs/julia-repl/files/50julia-repl-gentoo.el b/app-emacs/julia-repl/files/50julia-repl-gentoo.el
new file mode 100644
index 000000000000..8c76042f08d4
--- /dev/null
+++ b/app-emacs/julia-repl/files/50julia-repl-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'julia-repl-mode "julia-repl"
+ "Minor mode for interacting with a Julia REPL running inside a term." t)
+(add-hook 'julia-mode-hook 'julia-repl-mode)
diff --git a/app-emacs/julia-repl/files/julia-repl-force-compile.patch b/app-emacs/julia-repl/files/julia-repl-force-compile.patch
new file mode 100644
index 000000000000..6d7de553ce39
--- /dev/null
+++ b/app-emacs/julia-repl/files/julia-repl-force-compile.patch
@@ -0,0 +1,9 @@
+index 41df3f1..7d983f8 100644
+--- a/julia-repl.el
++++ b/julia-repl.el
+@@ -1,4 +1,4 @@
+-;;; julia-repl.el --- A minor mode for a Julia REPL -*- lexical-binding:t; no-byte-compile:t -*-
++;;; julia-repl.el --- A minor mode for a Julia REPL -*- lexical-binding:t; -*-
+
+ ;; Copyright (C) 2016 Tamas K. Papp
+ ;; Author: Tamas Papp <tkpapp@gmail.com>
diff --git a/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
new file mode 100644
index 000000000000..b52af57974bd
--- /dev/null
+++ b/app-emacs/julia-repl/julia-repl-1.3.0_p20220225.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=6c1d63511fb2b3b3f2e342eff6a375d78be6c12c
+NEED_EMACS=25.1
+
+inherit optfeature elisp
+
+DESCRIPTION="Run an inferior Julia REPL in a terminal inside Emacs"
+HOMEPAGE="https://github.com/tpapp/julia-repl/"
+SRC_URI="https://github.com/tpapp/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-emacs/s"
+RDEPEND="
+ ${BDEPEND}
+ app-emacs/julia-mode
+"
+
+DOCS=( CHANGELOG.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-force-compile.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l ert -l ./${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ rm ./${PN}-tests.el || die
+
+ elisp_src_install
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "running Julia inside VTerm" app-emacs/vterm
+}
diff --git a/app-emacs/julia-repl/metadata.xml b/app-emacs/julia-repl/metadata.xml
new file mode 100644
index 000000000000..0e443214e73b
--- /dev/null
+++ b/app-emacs/julia-repl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This is a minor mode for interacting with a Julia REPL running inside
+ Emacs. The julia process is started in an ANSI terminal (term), which
+ allows text formatting and colors, and interaction with the help system and
+ the debugger.
+ It is recommended that you use this minor mode with julia-mode.
+ </longdescription>
+ <upstream>
+ <changelog>
+ https://raw.githubusercontent.com/tpapp/julia-repl/master/CHANGELOG.md
+ </changelog>
+ <bugs-to>https://github.com/tpapp/julia-repl/issues/</bugs-to>
+ <remote-id type="github">tpapp/julia-repl</remote-id>
+ </upstream>
+</pkgmetadata>