summaryrefslogtreecommitdiff
path: root/app-emacs/graphql/graphql-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-emacs/graphql/graphql-0.1.1.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-emacs/graphql/graphql-0.1.1.ebuild')
-rw-r--r--app-emacs/graphql/graphql-0.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/graphql/graphql-0.1.1.ebuild b/app-emacs/graphql/graphql-0.1.1.ebuild
new file mode 100644
index 000000000000..9dccfdd1f85d
--- /dev/null
+++ b/app-emacs/graphql/graphql-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="GraphQL utilities"
+HOMEPAGE="https://github.com/vermiculus/graphql.el"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+# Tries to download emake tool on the fly
+RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f examples.el || die
+
+ default
+}