summaryrefslogtreecommitdiff
path: root/app-emacs/graphql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-emacs/graphql
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-emacs/graphql')
-rw-r--r--app-emacs/graphql/Manifest4
-rw-r--r--app-emacs/graphql/files/50graphql-gentoo.el1
-rw-r--r--app-emacs/graphql/graphql-0.1.1.ebuild29
-rw-r--r--app-emacs/graphql/metadata.xml17
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/graphql/Manifest b/app-emacs/graphql/Manifest
new file mode 100644
index 000000000000..cb1d1a5d6475
--- /dev/null
+++ b/app-emacs/graphql/Manifest
@@ -0,0 +1,4 @@
+AUX 50graphql-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST graphql-0.1.1.tar.gz 6021 BLAKE2B 62755fda880042e00942acc6dbf98219521c92d052eeb0c584e8bb83ae8fdcea46185270f5dff8c89762d11b409e31b42d4ae62ab6831b04437ac0de517f442e SHA512 53f4c8b70be07f38b3554c4488a98ccdb956a68585955c7afd9df52d9d39cfaf7cc0efcadae1f42099495b8729851d089cd03d4570ed2a91a3354dd19f12d5bb
+EBUILD graphql-0.1.1.ebuild 609 BLAKE2B 87f8cddcb8160dd6c00cc6223a9bd0832096baa8caee12bc399f02180b4f83cbe8cd5b6deefbebfcf2f75d40f26407e0f215ff46086c17eae85c82a198f592e7 SHA512 7bea39ce0132e346b42641f14902c4891581cc1dd0ff81c3e00d6b06be33ce23eb7de4f71d8a48dcec7a7eb76c4104b1bd68e06d88e65fa3cd3de4f66183686c
+MISC metadata.xml 550 BLAKE2B 267d363cc3676b0f8d1dca5703f6c7a8cfaebb1c6b714a2bebd1806e9b28b3a28f37fac15a1907d64fa9c6bc9813c5995f7591e965f3514963266de1a8c34f7e SHA512 534f483eead85b46f513cab779d6f2e0f4fef965de9e81f82735af4ab5d7c7c7db9d08411dd4ac2590031332b47742bd8d959d2ca3a561bc0131b23ba770ab39
diff --git a/app-emacs/graphql/files/50graphql-gentoo.el b/app-emacs/graphql/files/50graphql-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/graphql/files/50graphql-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/graphql/graphql-0.1.1.ebuild b/app-emacs/graphql/graphql-0.1.1.ebuild
new file mode 100644
index 000000000000..9dccfdd1f85d
--- /dev/null
+++ b/app-emacs/graphql/graphql-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="GraphQL utilities"
+HOMEPAGE="https://github.com/vermiculus/graphql.el"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+# Tries to download emake tool on the fly
+RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f examples.el || die
+
+ default
+}
diff --git a/app-emacs/graphql/metadata.xml b/app-emacs/graphql/metadata.xml
new file mode 100644
index 000000000000..010525da2380
--- /dev/null
+++ b/app-emacs/graphql/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+GraphQL.el provides a generally-applicable domain-specific language
+for creating and executing GraphQL queries against your favorite
+web services.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">vermiculus/graphql.el</remote-id>
+</upstream>
+</pkgmetadata>