summaryrefslogtreecommitdiff
path: root/app-emacs/exec-path-from-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 02:31:41 +0100
commit91e1f8a90b85372d757efd9a1fb7dd1685ea6b50 (patch)
treeebeff59a4470abb242c47417f217e36e21fe6a0c /app-emacs/exec-path-from-shell
parentae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (diff)
gentoo auto-resync : 17:08:2022 - 02:31:41
Diffstat (limited to 'app-emacs/exec-path-from-shell')
-rw-r--r--app-emacs/exec-path-from-shell/Manifest4
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild24
-rw-r--r--app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el2
-rw-r--r--app-emacs/exec-path-from-shell/metadata.xml20
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/exec-path-from-shell/Manifest b/app-emacs/exec-path-from-shell/Manifest
new file mode 100644
index 000000000000..f07d0e5a6436
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/Manifest
@@ -0,0 +1,4 @@
+AUX 50exec-path-from-shell-gentoo.el 84 BLAKE2B 0f3b62567ac7e3d501fe9d728cf380383f789f4c3107044747f2cfecd682f71404a49b4afa145f18e5dddc6f41247035fe72e01d6f3b362586017fdedc216c8e SHA512 42f18f03262f302c8ab28b0db1f285ab27caa19cf9acc4df4b289bd24d0e379e847022f59d5ac627ea3ebe1ba1c3f0a55ecba94d3b7f6825bcfee324983e216f
+DIST exec-path-from-shell-1.12.tar.gz 17125 BLAKE2B 01440c4f484fa2e584c40961cc3a0199a812072b3a41c78833a43bd57105e677077f902ef40dbb68eeaaa84fc511d9e02d7fabdbd7c86a0bc57e1ba88aaa6888 SHA512 62f0f89f542cbf0edaf163c1dfd4fac8bb532898f8eb5a9e068a991eaddb5e6ecb1813fc76252dc2d48b42b9ab602082f612d241613002b1a37b4f7d5f5d4f3c
+EBUILD exec-path-from-shell-1.12.ebuild 528 BLAKE2B e9885d2c3809df21485e8969e6961f17fee9ff76448ba5a5500ffe4094c03fae37888133be7f781ddb2934a5b9977c98abb1147cdc358d291988cbe5e385dc37 SHA512 0f760babb7aaed92de44f8d1e897fb56865b1c1b53ccd30d9c408e7d6e8ea22cbb4d45c717d6d7e962b8d958765e1e50e4aee1c630d0d912f4bc23dc555fc5ac
+MISC metadata.xml 817 BLAKE2B 013b0baf63e956f1c9bfa234348c4ec80888321257fda7569324033c1c48418b979972d48d8bbcfb83d75cfb44fae9a0cd484bd1e7e7a65c7fec58542aeccd7e SHA512 78d256c67f5e15e1895e13ab57fbe8d80897184f2aa04698df4a4de60ab0da5dbbb59c65f3696e2e548456eee249550bffdda45025abd3844c0fbb6c6886cb02
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
new file mode 100644
index 000000000000..f21f1c54ffd5
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
new file mode 100644
index 000000000000..6fa79c9aefcf
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/files/50exec-path-from-shell-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "exec-path-from-shell-autoloads" nil t)
diff --git a/app-emacs/exec-path-from-shell/metadata.xml b/app-emacs/exec-path-from-shell/metadata.xml
new file mode 100644
index 000000000000..053f64ad6502
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This library allows the user to set Emacs' `exec-path' and $PATH from the
+ shell path, so that `shell-command', `compile' and the like work as
+ expected. It also allows other environment variables to be retrieved from
+ the shell, so that Emacs will see the same values you get in a terminal.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/purcell/exec-path-from-shell/issues/</bugs-to>
+ <remote-id type="github">purcell/exec-path-from-shell</remote-id>
+ </upstream>
+</pkgmetadata>