summaryrefslogtreecommitdiff
path: root/app-emacs/embark/embark-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
commit1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (patch)
tree7e7d76b763f13b5096b3bbb3b164edc87dc72b27 /app-emacs/embark/embark-9999.ebuild
parentdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (diff)
gentoo auto-resync : 28:06:2023 - 07:37:01
Diffstat (limited to 'app-emacs/embark/embark-9999.ebuild')
-rw-r--r--app-emacs/embark/embark-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/embark/embark-9999.ebuild b/app-emacs/embark/embark-9999.ebuild
new file mode 100644
index 000000000000..38aa5db83044
--- /dev/null
+++ b/app-emacs/embark/embark-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}