summaryrefslogtreecommitdiff
path: root/app-emacs/citeproc-el
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 20:18:34 +0100
commitf1cd8f3514f8b9fbc1cc9cfe0dd08a8cb258e87a (patch)
treee16b2f573ffa54d21accbf0dfc3647b47b0578c8 /app-emacs/citeproc-el
parente9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (diff)
gentoo auto-resync : 10:08:2022 - 20:18:34
Diffstat (limited to 'app-emacs/citeproc-el')
-rw-r--r--app-emacs/citeproc-el/Manifest4
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild47
-rw-r--r--app-emacs/citeproc-el/files/50citeproc-el-gentoo.el1
-rw-r--r--app-emacs/citeproc-el/metadata.xml27
4 files changed, 79 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/Manifest b/app-emacs/citeproc-el/Manifest
new file mode 100644
index 000000000000..8c0b587e41fc
--- /dev/null
+++ b/app-emacs/citeproc-el/Manifest
@@ -0,0 +1,4 @@
+AUX 50citeproc-el-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST citeproc-el-0.9.1.tar.gz 108702 BLAKE2B 409548f50baa37c03906d3435569b8f75d8f0238b2d463e22ab0428a0536c6b12e2bf723a8fc4684fae17b31a9d46121d0ebcfd3cd03ada5b0838c8f0e042106 SHA512 6eab58576b4f851f44b45e444ee43a9022651dd322efa77b6162db0906a8cace70458b0a1431ed3d995d480d38944bafc13e76e04e5a310e8c14ffc28888953f
+EBUILD citeproc-el-0.9.1.ebuild 909 BLAKE2B 6416b809b0f5cb6fa84b9f092103e4892f73720275052209604fec5aca036251929a5cedc99feec206f8199859c9c8883fd8ad6e9ae52023e968fde48d8468ac SHA512 0796d18c86de02a2bb137baecce1fd9a65eb20fa46e8d9cefea9d9560da51e1f5f0dfa7de2e327769ec5b076881f2ee37fbda53d4c6a8ada5f8ea2488c3a4e2f
+MISC metadata.xml 1335 BLAKE2B 100bfe27f5d296a91fa300faa044dd80ba7762e53468b9f4c62c1ffaf23cfbcea7c611451f1ec82385d29d8a0400812ac536c302ae6f4b615bf25583d98c8b8b SHA512 2e9ce67c3e10f25113fe65a9307139b1e493ecb2b6cf15c34c5b4659279361fba04b5830cc20fb7a2818a290067236811754ca92607c8d991ea505657dad7570
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
new file mode 100644
index 000000000000..b59dcf28c0e8
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}
diff --git a/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/citeproc-el/files/50citeproc-el-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/citeproc-el/metadata.xml b/app-emacs/citeproc-el/metadata.xml
new file mode 100644
index 000000000000..33a57a1b947e
--- /dev/null
+++ b/app-emacs/citeproc-el/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ citeproc-el is an Emacs Lisp library for rendering citations and
+ bibliographies in styles described in the Citation Style Language (CSL), an
+ XML-based, open format to describe the formatting of bibliographic
+ references (see http://citationstyles.org/ for further information on CSL).
+ The library implements most of the CSL 1.0.2 specification, including such
+ features as citation disambiguation, cite collapsing and subsequent author
+ substitution, and passes more than 70% of the tests in the CSL Test Suite.
+ In addition to the standard CSL-JSON data format, citeproc-el has
+ rudimentary support for reading bibliographic data from BibTeX, biblatex
+ and org-bibtex bibliographies and can produce output in several formats
+ including HTML and org-mode markup (see Supported output formats for the
+ full list).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/andras-simonyi/citeproc-el/issues/</bugs-to>
+ <remote-id type="github">andras-simonyi/citeproc-el</remote-id>
+ </upstream>
+</pkgmetadata>