summaryrefslogtreecommitdiff
path: root/app-emacs/chess/chess-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/chess/chess-2.0.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/chess/chess-2.0.4.ebuild')
-rw-r--r--app-emacs/chess/chess-2.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/chess/chess-2.0.4.ebuild b/app-emacs/chess/chess-2.0.4.ebuild
new file mode 100644
index 000000000000..67203f003713
--- /dev/null
+++ b/app-emacs/chess/chess-2.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="https://elpa.gnu.org/packages/chess.html
+ https://www.emacswiki.org/emacs/ChessMode"
+# Taken from https://elpa.gnu.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz
+ mirror://gentoo/emacs-chess-sounds-${PV%.*}.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-${PV%.*}.tar.bz2"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Free alternatives first, otherwise follow the ordering in the upstream
+# chess-default-engine (in chess.el). Rearrange chess-default-engine in
+# the site-init file accordingly.
+RDEPEND="|| ( games-board/stockfish
+ games-board/fruit
+ games-board/gnuchess
+ games-board/phalanx
+ games-board/sjeng
+ games-board/crafty )"
+
+ELISP_REMOVE="chess-pkg.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
+DOCS="AUTHORS NEWS TODO"
+
+src_install() {
+ elisp_src_install
+ doinfo chess.info
+ insinto "${SITEETC}/${PN}"
+ doins chess-eco.fen chess-polyglot.bin
+ doins -r "${WORKDIR}"/{sounds,pieces}
+}