summaryrefslogtreecommitdiff
path: root/app-emacs/chess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/chess
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/chess')
-rw-r--r--app-emacs/chess/Manifest6
-rw-r--r--app-emacs/chess/chess-2.0.4.ebuild41
-rw-r--r--app-emacs/chess/files/50chess-gentoo-2.0.4.el36
-rw-r--r--app-emacs/chess/metadata.xml30
4 files changed, 113 insertions, 0 deletions
diff --git a/app-emacs/chess/Manifest b/app-emacs/chess/Manifest
new file mode 100644
index 000000000000..6cb79888b1a5
--- /dev/null
+++ b/app-emacs/chess/Manifest
@@ -0,0 +1,6 @@
+AUX 50chess-gentoo-2.0.4.el 1570 BLAKE2B b209711df279d0cfb7900b3acc41c0077080d8063258aa49f86cd884f4283c2bfb8403644d64a0c4914d35d6fd9d411e8bc7037cb8081868c1a8c87795978c85 SHA512 cef5a4826f0f8eb02ecbbdddb9c2d8dab54c657c42877e415262ae8474c4a591135353a31b6a56981ab7b6107f79f2aa821b7b19fa7a63b1af95f6088e5deb46
+DIST chess-2.0.4.tar.xz 364620 BLAKE2B cf02ff2734d675ac39b6b00869abe233a71af330fa60114d12092604d0173c6da5ad5c2e4cf3e2262c99cfc598abdbbe02a7df4eaadda7c628c8b9c48d8f8a8a SHA512 2c8155185878fec8b45ab84b7723f4af0f518fc81ab7534c36c09c96a9a30cb20da26c2a89320cc5a9f9d8991e4516da393e82658a7f15642929591d1b6a0e99
+DIST emacs-chess-pieces-2.0.tar.bz2 297687 BLAKE2B b97f6bbfdb4573e7a59e50431ac4ce68d2acd698ed57a2a2b9dfc83c7afdadc3ca244e8a0d55fa29eebcf7234001062606c0d21c80675864804a27d47deb6b93 SHA512 e1ee59a338b68796fd60f8693f4ff8bf20ded535c516916cc8b1f4cf00ff696ca1eead844e2a6a9a1f2578a70370d7a67cbadb6ae454ae16b2ae93864e1b1f94
+DIST emacs-chess-sounds-2.0.tar.bz2 3390098 BLAKE2B 1babc804a4ef05d4da4cb56d0829e93dfef84e703b1c56dfcbd14f941357dee68e4dffaff13b30498037f907a62c79751f53be33582ecf5c1c266d8aea492fb1 SHA512 f07894dd7a6e43450405c0eee8d1d95a08925ca8ebd5ca7e584eca45369cb2aa8eecb754b351d1977f473b520288d3e3e9a8ebe73216d14e26345b44e498efb4
+EBUILD chess-2.0.4.ebuild 1144 BLAKE2B 144737ab9beef026a6a962e25258fc34d84d35b22fff8417733753e8c6253b25f5288e0db36aed2e129f68ccb157dcedbfee261c776e376d92a2fefb98b20214 SHA512 f997352699a9ad7397a30ca873435578d2194b31eb4805a05f32005d04000e24279bd365f7a267bee53e5c0cc1d736e038b595fef876f077d28e5eed3d5bd72f
+MISC metadata.xml 1318 BLAKE2B aba8a35412d7488de868ce812c2ceccf16989e08f7d390492da8f2e74ff4550b7f1255ba7176c1eba4c5ae4c9f5050040cef93619265e6e28e425b429f52c8ad SHA512 f2baec1ee8947d0f889e58c14ac9c3414ebca90dec48d2b865f60a4d5047c408717250b72ac7169f37aeb7a2fbaaee5bd968109d922417979f7e694a2b39339a
diff --git a/app-emacs/chess/chess-2.0.4.ebuild b/app-emacs/chess/chess-2.0.4.ebuild
new file mode 100644
index 000000000000..67203f003713
--- /dev/null
+++ b/app-emacs/chess/chess-2.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="https://elpa.gnu.org/packages/chess.html
+ https://www.emacswiki.org/emacs/ChessMode"
+# Taken from https://elpa.gnu.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz
+ mirror://gentoo/emacs-chess-sounds-${PV%.*}.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-${PV%.*}.tar.bz2"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Free alternatives first, otherwise follow the ordering in the upstream
+# chess-default-engine (in chess.el). Rearrange chess-default-engine in
+# the site-init file accordingly.
+RDEPEND="|| ( games-board/stockfish
+ games-board/fruit
+ games-board/gnuchess
+ games-board/phalanx
+ games-board/sjeng
+ games-board/crafty )"
+
+ELISP_REMOVE="chess-pkg.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
+DOCS="AUTHORS NEWS TODO"
+
+src_install() {
+ elisp_src_install
+ doinfo chess.info
+ insinto "${SITEETC}/${PN}"
+ doins chess-eco.fen chess-polyglot.bin
+ doins -r "${WORKDIR}"/{sounds,pieces}
+}
diff --git a/app-emacs/chess/files/50chess-gentoo-2.0.4.el b/app-emacs/chess/files/50chess-gentoo-2.0.4.el
new file mode 100644
index 000000000000..b263ddd84a02
--- /dev/null
+++ b/app-emacs/chess/files/50chess-gentoo-2.0.4.el
@@ -0,0 +1,36 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'chess "chess"
+ "Start a game of chess, playing against ENGINE (a module name)." t)
+(defalias 'chess-session 'chess)
+(autoload 'chess-create-display "chess"
+ "Create a display, letting the user's customization decide the style.")
+(autoload 'chess-link "chess-link"
+ "Play out a game between two engines, and watch the progress." t)
+(autoload 'chess-pgn-read "chess-pgn"
+ "Read and display a PGN game after point." t)
+(autoload 'chess-pgn-mode "chess-pgn"
+ "A mode for editing chess PGN files." t)
+(defalias 'pgn-mode 'chess-pgn-mode)
+(autoload 'chess-puzzle "chess-puzzle"
+ "Pick a random puzzle from FILE, and solve it against the default engine." t)
+(autoload 'chess-fischer-random-position "chess-random"
+ "Generate a Fischer Random style position.")
+(autoload 'chess-tutorial "chess-tutorial"
+ "A simple chess training display." t)
+(autoload 'chess-ics "chess-ics"
+ "Connect to an Internet Chess Server." t)
+
+(add-to-list 'auto-mode-alist '("\\.pgn\\'" . chess-pgn-mode))
+
+(setq chess-images-directory "@SITEETC@/pieces/xboard")
+(setq chess-sound-directory "@SITEETC@/sounds")
+(setq chess-eco-hash-table "@SITEETC@/chess-eco.fen")
+(setq chess-polyglot-book-file "@SITEETC@/chess-polyglot.bin")
+
+;; Change the order of the engine preference list to coincide with
+;; the order of dependencies in the ebuild. The user can override this
+;; using "M-x customize-group RET chess RET".
+(setq chess-default-engine
+ '(chess-stockfish chess-fruit chess-gnuchess chess-phalanx chess-sjeng
+ chess-crafty chess-ai))
diff --git a/app-emacs/chess/metadata.xml b/app-emacs/chess/metadata.xml
new file mode 100644
index 000000000000..8fb55ab05df2
--- /dev/null
+++ b/app-emacs/chess/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ chess.el is an Emacs Lisp library and several clients on top of the
+ underlying library functionality for performing various activities related
+ to the game of chess.
+
+ You can play against an external chess program such as gnuchess, crafty,
+ phalanx or sjeng. All of them are publically available, and chess.el will
+ automatically detect which one you have installed, provided they have
+ standard executable program names, and are in a located in a directory which
+ is part of the PATH. See the customisable variable `chess-default-engine'.
+
+ You can also play against another human or computer over the internet
+ (through a direct Emacs-to-Emacs connection, or on one of the Internet Chess
+ Servers like freechess.org or chessclub.com), or even against a very simple
+ chess thinking module implemented in pure Emacs Lisp.
+
+ chess.el also provides a mode for editing Portable Game Notation (PGN) files.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="sourceforge">emacs-chess</remote-id>
+</upstream>
+</pkgmetadata>