summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
commitcc901a8ce7c6bfe97e3b4f048619693d360ae348 (patch)
treec250ff07a4d508fa08b487b616e0ae8aff2f0d8e /app-crypt/acme
parentc9badf79e4669147edb94182af5776072f2ffaea (diff)
gentoo auto-resync : 10:02:2024 - 11:34:00
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest2
-rw-r--r--app-crypt/acme/acme-2.9.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2a35aefb201d..ad3975313ab8 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD acme-2.8.0.ebuild 1506 BLAKE2B a52faf8a92b81d14ff98e25a06c8799939bb729358313e783ebdd27debab435c224f05a09a8dc7e8fd432eb17f6e5e3db4abf987ccd8336e729adf6e52c58752 SHA512 d6d6a3d53f67c102b11444687ae8464f074de18112f8e18749afb22d25c611383832104034333fa25ade05387de37eb19931592984e4d76139c257fd6e224a7e
+EBUILD acme-2.9.0.ebuild 1510 BLAKE2B a3174a516383781ffa50ef87b3c413fc0445fe242c7708ffc660e2dcfb5db356d622f90caf607830596729f2056bf8adc9a942fe683e0602f536ac24dfda9409 SHA512 f91eb5ef2ce8a0ae4c1443a49159137488f793e49320e1314e34f5e9179e9dcf1ac1c5c0046dc1c20a4032048086ada99950c900f95b2c5ce8ac1653490a5021
EBUILD acme-9999.ebuild 1510 BLAKE2B 90d6f2b5c740938e43199b63deabb24c58482977654f6c2a4eb76493961772a4f296452af46dbb1b9437c823a6916b6d2a5d6a3155793198720b5988604e9239 SHA512 b6324a3f7aae817df99ea8e58d21ba380824126dd810717a0053c4849754b833003d7cf399aefb514d9377accbb823ac81b2c9d0c0a9d095313d701e5ddc3f09
MISC metadata.xml 401 BLAKE2B 30a2ac1f03749a8e3bb98723c57f47ab6bcf7bfa58c2b6e21c309fae279feca0d3612df6c2a1dafaf27b4f0781c583a140322feac1a1cf2c13e50861cad129ea SHA512 d8e725b71ca81ce4ca6565ed58271b283c25394448f0f48f726f232122577c33d5b2d726e117419b2fae99f9dae29a8080bb9564eccbca13368c83988cf3da01
diff --git a/app-crypt/acme/acme-2.9.0.ebuild b/app-crypt/acme/acme-2.9.0.ebuild
new file mode 100644
index 000000000000..2c5bdf643ecf
--- /dev/null
+++ b/app-crypt/acme/acme-2.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest