summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
commitcc901a8ce7c6bfe97e3b4f048619693d360ae348 (patch)
treec250ff07a4d508fa08b487b616e0ae8aff2f0d8e /app-crypt
parentc9badf79e4669147edb94182af5776072f2ffaea (diff)
gentoo auto-resync : 10:02:2024 - 11:34:00
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin24799 -> 24784 bytes
-rw-r--r--app-crypt/acme/Manifest2
-rw-r--r--app-crypt/acme/acme-2.9.0.ebuild60
-rw-r--r--app-crypt/certbot-apache/Manifest2
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild50
-rw-r--r--app-crypt/certbot-nginx/Manifest2
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild52
-rw-r--r--app-crypt/certbot/Manifest2
-rw-r--r--app-crypt/certbot/certbot-2.9.0.ebuild62
9 files changed, 232 insertions, 0 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 5472485d77cf..d8f59dfabc6b 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2a35aefb201d..ad3975313ab8 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD acme-2.8.0.ebuild 1506 BLAKE2B a52faf8a92b81d14ff98e25a06c8799939bb729358313e783ebdd27debab435c224f05a09a8dc7e8fd432eb17f6e5e3db4abf987ccd8336e729adf6e52c58752 SHA512 d6d6a3d53f67c102b11444687ae8464f074de18112f8e18749afb22d25c611383832104034333fa25ade05387de37eb19931592984e4d76139c257fd6e224a7e
+EBUILD acme-2.9.0.ebuild 1510 BLAKE2B a3174a516383781ffa50ef87b3c413fc0445fe242c7708ffc660e2dcfb5db356d622f90caf607830596729f2056bf8adc9a942fe683e0602f536ac24dfda9409 SHA512 f91eb5ef2ce8a0ae4c1443a49159137488f793e49320e1314e34f5e9179e9dcf1ac1c5c0046dc1c20a4032048086ada99950c900f95b2c5ce8ac1653490a5021
EBUILD acme-9999.ebuild 1510 BLAKE2B 90d6f2b5c740938e43199b63deabb24c58482977654f6c2a4eb76493961772a4f296452af46dbb1b9437c823a6916b6d2a5d6a3155793198720b5988604e9239 SHA512 b6324a3f7aae817df99ea8e58d21ba380824126dd810717a0053c4849754b833003d7cf399aefb514d9377accbb823ac81b2c9d0c0a9d095313d701e5ddc3f09
MISC metadata.xml 401 BLAKE2B 30a2ac1f03749a8e3bb98723c57f47ab6bcf7bfa58c2b6e21c309fae279feca0d3612df6c2a1dafaf27b4f0781c583a140322feac1a1cf2c13e50861cad129ea SHA512 d8e725b71ca81ce4ca6565ed58271b283c25394448f0f48f726f232122577c33d5b2d726e117419b2fae99f9dae29a8080bb9564eccbca13368c83988cf3da01
diff --git a/app-crypt/acme/acme-2.9.0.ebuild b/app-crypt/acme/acme-2.9.0.ebuild
new file mode 100644
index 000000000000..2c5bdf643ecf
--- /dev/null
+++ b/app-crypt/acme/acme-2.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 57a284d74e1b..64a5b162bb43 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD certbot-apache-2.8.0.ebuild 1076 BLAKE2B 7bc29c752b9569208f10d5b83d21d2a0678fc09fdf7f31aa8787be1c14257f0c85f9287fdaf0ed4ce2a140352231abfd1ee99a1a9ec84f549fa03a114c7a74e6 SHA512 077932361553e4e83cd6334d899e19ad693a67ec8d53455c0be5d29c238c3769b6236aba48518f93a0bf8db17787cb4e030cbba6c6e92c2eb728223708a6774b
+EBUILD certbot-apache-2.9.0.ebuild 1078 BLAKE2B 34b1285228ec82c3634afc07a62077daa287224ea5072fa213de4cad99e3b82fc09e51942c1d5673f2504d74a21fbe2d3c35617614d86ee57a9ae25cca2863d0 SHA512 b977405a50c30b2e7bc07426392c13be42a11269984fdd591c41b5f68fd5cb3e0ea89c6e767082955807255d19356764ede65a37b40bddfc1f9aa4af3787faaf
EBUILD certbot-apache-9999.ebuild 1078 BLAKE2B 4c6a746c517a83b34a69b3501317ccf29a341c5c5e02e8a0129992e53c757af939582566694a3c927801bfdc0d8a743a83b81ac76a523a0a7be0bc283eb0e747 SHA512 776da4da5cee6e6840e323aab45f741e16821ed5231f600fe7454016de55c040863bdaa70f5f4f8cb4f88e8d8d5f123d51487268dc15770e4496267990a41992
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild b/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild
new file mode 100644
index 000000000000..07c1b3fa631b
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-apache}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64, arm64 and x86 because of dev-python/python-augeas
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 4b96430db22b..9ed5de28d064 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD certbot-nginx-2.8.0.ebuild 1182 BLAKE2B 40bc47f9e03d808a7c168b151851e42f472d726df042e1e7c36983ccbacda8ec7d26736713fdbf8f5fa728ecb9206195c74483441e830e72b66f2389010ade09 SHA512 d124f5d851c4b57d143e20f13d360407489d4eaaaeebf9b77023350f6a207d5ff255c5ffe42e1873a73c4504ce999f34ecdd30c342e22934c8d9da48961bcbf0
+EBUILD certbot-nginx-2.9.0.ebuild 1186 BLAKE2B 5f5a85510083fde5597362b8b97a8909580a285905276bcea01893d478b6f7d6c64d4705bb026bc021a320e82bedf08eea223c193aaa467e548619b206ddca7c SHA512 4981c8548715064cd75a635a0dfb95bdb99b1d2c9259101943ff60ef0d69053135fd7be9abe5d746157d15a5f5f11a8b7d10d25a72ff4115761d9e4a61887784
EBUILD certbot-nginx-9999.ebuild 1186 BLAKE2B 65530ebcce256a39830ef523a31cfc8ee371b7e0331a618d65d8351fa3bc2819bfe5b8941f5a2a10664ddfb66d40fb9e16e9250ed00323ebaf0996893c44a966 SHA512 89c10ba181f1f83e04ad06e05db20dea7bec7b1943fd69d07f5bce8a9544f798272f458c381ca357c7e7e22c62cd2dec6c6972c68938895263bec0041e2cd792
MISC metadata.xml 335 BLAKE2B 048854ec6bc919f9bf9b0bc74e7c291841cbfea0e571f43437937c5dd78cc65f9df53463adcf313441e01323491709b462bd9bc364876eb1508a83b3426b6b78 SHA512 25ac45574a568e362c419dfbeade4a977afa2885e7b32fb4c3d4c765450b09aa98cf419df1a39ab194518ad6f2b582e162d4dd4eec14f278635d63bf66352523
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild
new file mode 100644
index 000000000000..c3322ba11923
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-nginx}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 12c25b5cdb66..f39c7c70ed85 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD certbot-2.8.0.ebuild 1542 BLAKE2B ae50a268d1cf78da60ec04063d8c6df338e96cae6c0fb457401d69e3f63c9f4640d12bb9f5d157cd50e1a098a0d998d4f788399348daa21a8a9cde8bc270a39c SHA512 63f065d7ce851f5774d64946708fee5234adc6e3f97995b7381f7d6d3ed917611b69223b30ec8d061a91fd4ece70ecc42544f50de08c6779219564eb5c12e487
+EBUILD certbot-2.9.0.ebuild 1546 BLAKE2B 88743f6d0f350b5f9d2811c443d9c7ea00c3970c18a682de0993d7e3a239578c10d8638df987a1707bdea693de4959aa4784dacccf73dac618275f5622af6167 SHA512 9f248366bfa8f4a54b19c2c2819b1887efed72d484a2af03eb590c810244827e697c973f9a8d402bd6df71ba6b293e5f323700fcd30982af9af725b63cd75f2b
EBUILD certbot-9999.ebuild 1546 BLAKE2B babd7b37f08f1bec100a6c677e7c2b91c8f93b8c60407991fb2bc582ce98079168412dc64ae137d0298b61ad360d4aef9b6720ec1ff120bf2c6f08f17138a6d3 SHA512 20d19fb38e4feb7999bf5d393b89596e8654d728f0027328ad6382e1bf12275034fc6cacca0732468ddba6dcec2d40a335d253b05f8302e438dd4c3c5638aca7
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot/certbot-2.9.0.ebuild b/app-crypt/certbot/certbot-2.9.0.ebuild
new file mode 100644
index 000000000000..0f29c796b738
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.9.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest