summaryrefslogtreecommitdiff
path: root/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild')
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
new file mode 100644
index 000000000000..d95863cf391c
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed are removed from specified directories"
+HOMEPAGE="https://pagure.io/tmpwatch"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-boottime.patch"
+)
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}"
+}