summaryrefslogtreecommitdiff
path: root/app-admin/tmpwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/tmpwatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/Manifest5
-rw-r--r--app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch30
-rw-r--r--app-admin/tmpwatch/files/tmpwatch.cron47
-rw-r--r--app-admin/tmpwatch/metadata.xml5
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild36
5 files changed, 123 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/Manifest b/app-admin/tmpwatch/Manifest
new file mode 100644
index 000000000000..497f646f974c
--- /dev/null
+++ b/app-admin/tmpwatch/Manifest
@@ -0,0 +1,5 @@
+AUX tmpwatch-2.11-boottime.patch 1034 BLAKE2B 37d257d39c8b7734e08f2498d07ac1d30e029a22c6ba70f2127f5a6a2d443555794022590e31445479ff145b9440695682aeb5be0102929ee9630c8a6527ce44 SHA512 6ad3cfe0dcd1a14d071ac64ca09279aae853c3b5a47604d99c2ff24319145d5c599ed6e780ac7eb9a2e2d185495e9d7e2133c905490b647f6b639a4bcd0def92
+AUX tmpwatch.cron 1533 BLAKE2B fd6e4ed53bb72e881a0dc92301ec04cf376dba40c2294973daaf8a353972664fb56da6e0f17b3ac161e189f9b7e5b9e883a7d2b5f64e4f909206432fb1163a90 SHA512 9c96eaccc70d6eadac1233b6cd6772c61dbe8fed348fbe45d729bba8d8434f32bb4ba800cf92f151d7576763f7fde7c5c25b55293ecdac5f5254ce387da8b016
+DIST tmpwatch-2.11.tar.bz2 145609 BLAKE2B ee66c77138e6f35030de817528ece1b3fa19622804e179fbc5c70c27281a52b8e8f7c7f631c9de73eb05085363852e91ee5a619de7db9a597a9f88afd95e164b SHA512 9242c5e1812c2ffc756cfc4cdc3023d0c0515e7c180e58ca3a838aa075d09fe4dc08dbc9afbc87ce3382e8aa8cb80a70e406deeab4ce10b39b6845d667989d97
+EBUILD tmpwatch-2.11-r2.ebuild 704 BLAKE2B 51e32787779599dd5a1a5bd9074e8c2eade4dea631cb9ff18137dc2ff1b19802e366b79ea55c37c4e196f9e9bc6c51f166f3681ca289f81c0adda53ac0e1de7e SHA512 297c4f41388e35eae3c1f0a4b13354bdb638b7df16d70e676be67faaead0a76ab71cd90c312cb97eed39bc18be1b06e674856e0afd832084a8cb0677a68b021b
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch b/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch
new file mode 100644
index 000000000000..b622c8d70e70
--- /dev/null
+++ b/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch
@@ -0,0 +1,30 @@
+Make boot time detection failures non-fatal. Taken from PLD Linux
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=468444
+PLD bug: https://bugs.launchpad.net/pld-linux/+bug/1034364
+Patch: https://github.com/pld-linux/tmpwatch/blob/master/tmpwatch-boottime.patch
+
+--- tmpwatch-2.11/tmpwatch.c~
++++ tmpwatch-2.11/tmpwatch.c
+@@ -666,9 +666,11 @@
+ time_t boot_time;
+
+ if (clock_gettime(CLOCK_REALTIME, &real_clock) != 0
+- || clock_gettime(CLOCK_BOOTTIME, &boot_clock) != 0)
+- message(LOG_FATAL, "Error determining boot time: %s\n",
++ || clock_gettime(CLOCK_BOOTTIME, &boot_clock) != 0) {
++ message(LOG_DEBUG, "Error determining boot time: %s\n",
+ strerror(errno));
++ socket_kill_time = 0; /* Never remove sockets */
++ } else {
+ boot_time = real_clock.tv_sec - boot_clock.tv_sec;
+ if (real_clock.tv_nsec < boot_clock.tv_nsec)
+ boot_time--;
+@@ -677,6 +679,7 @@
+ boot_time -= 2;
+
+ socket_kill_time = boot_time - grace_seconds;
++ }
+ #else
+ socket_kill_time = 0; /* Never remove sockets */
+ #endif
diff --git a/app-admin/tmpwatch/files/tmpwatch.cron b/app-admin/tmpwatch/files/tmpwatch.cron
new file mode 100644
index 000000000000..806b1453e552
--- /dev/null
+++ b/app-admin/tmpwatch/files/tmpwatch.cron
@@ -0,0 +1,47 @@
+#!/bin/sh
+# vim: ft=sh
+
+# This cron script contains several (commented out) examples. You may use
+# them as is, by uncommenting them, or modify them to suit your needs. Read
+# tmpwatch(8) for more information on tmpwatch parameters.
+
+### Variables ###
+
+TMPWATCH="/usr/sbin/tmpwatch"
+#PORTAGE_TMPDIR="$(portageq envvar PORTAGE_TMPDIR)/portage"
+#PORTAGE_LOGDIR="$(portageq envvar PORT_LOGDIR)"
+#DISTDIR="$(portageq distdir)"
+
+### EXAMPLES ###
+
+# NOTE: if you have noatime in /etc/fstab for any partitions you plan on
+# running tmpwatch on, you should obviously change any of the examples that
+# use atime (-u|--atime). Those that don't specify anything, default to
+# atime.
+
+# NOTE2: the time value is in HOURS!
+
+# Delete everything in /tmp that haven't been accessed in a week (>=168 hrs).
+#
+# if [[ -d /tmp ]]; then
+# ${TMPWATCH} --atime 168 /tmp
+# fi
+
+# Delete everything in PORTAGE_TMPDIR that hasn't been modified in 2 weeks.
+#
+# if [[ -d ${PORTAGE_TMPDIR:-/var/tmp/portage} && -z $(/usr/bin/pgrep emerge) ]]; then
+# ${TMPWATCH} --mtime --all 336 ${PORTAGE_TMPDIR:-/var/tmp/portage}
+# fi
+
+# Delete everything in DISTDIR that hasn't been accessed in 6 months (going
+# by 30 day months)
+#
+# if [[ -d ${DISTDIR:-/usr/portage/distfiles} ]]; then
+# ${TMPWATCH} --atime --fuser 4320 ${DISTDIR:-/usr/portage/distfiles}
+# fi
+
+# Delete everything in PORTAGE_LOGDIR that hasn't been accessed in 4 weeks
+#
+# if [[ -d ${PORTAGE_LOGDIR:-/var/log/portage} ]]; then
+# ${TMPWATCH} --atime 772 ${PORTAGE_LOGDIR:-/var/log/portage}
+# fi
diff --git a/app-admin/tmpwatch/metadata.xml b/app-admin/tmpwatch/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-admin/tmpwatch/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
new file mode 100644
index 000000000000..d95863cf391c
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed are removed from specified directories"
+HOMEPAGE="https://pagure.io/tmpwatch"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-boottime.patch"
+)
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}"
+}