summaryrefslogtreecommitdiff
path: root/app-admin/sxid/sxid-4.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
commitea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (patch)
tree60dac1902fc2665fd22fc2e4e4a60186cc7e361b /app-admin/sxid/sxid-4.2-r3.ebuild
parentefca79f216bfeffd55e7731fbf24126d093e1084 (diff)
gentoo auto-resync : 15:09:2023 - 10:49:51
Diffstat (limited to 'app-admin/sxid/sxid-4.2-r3.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.2-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.2-r3.ebuild b/app-admin/sxid/sxid-4.2-r3.ebuild
new file mode 100644
index 000000000000..b62bc5855760
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="https://linukz.org/sxid.shtml https://github.com/taem/sxid"
+SRC_URI="https://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-sxid )
+"
+
+DOCS=( NEWS README docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i 's/bindir/sbindir/g' source/Makefile.in || die
+ sed -i -e 's/configure.in/configure.ac/g' Makefile || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+}