summaryrefslogtreecommitdiff
path: root/app-admin/sxid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 10:49:51 +0100
commitea3e1bbf643d1d8892f4df05e4f05c1b2a2125d8 (patch)
tree60dac1902fc2665fd22fc2e4e4a60186cc7e361b /app-admin/sxid
parentefca79f216bfeffd55e7731fbf24126d093e1084 (diff)
gentoo auto-resync : 15:09:2023 - 10:49:51
Diffstat (limited to 'app-admin/sxid')
-rw-r--r--app-admin/sxid/Manifest1
-rw-r--r--app-admin/sxid/sxid-4.2-r3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/sxid/Manifest b/app-admin/sxid/Manifest
index 967d48cd72f7..f55574cfce8b 100644
--- a/app-admin/sxid/Manifest
+++ b/app-admin/sxid/Manifest
@@ -1,3 +1,4 @@
DIST sxid-4.2.tar.gz 41827 BLAKE2B c436ffd1b05306508c0ab0e4236cb3968d4456ae0686357a3a2c2a587fdbdaf8e760d5ff8198188c23854b080a91a35fc27a9717ab28f6907deb887a7b455cea SHA512 ed2832a0ffa89a41eba39e116122878b830c46ee7bfb906652606cff61fe16bc28ab6e6b4a802cc2436d9b3a7bdd734a827f007e6f1ce14ca84a9015d3a37a69
EBUILD sxid-4.2-r2.ebuild 818 BLAKE2B a4d7c7526543af0f2b4412a5fbd8d48df1f622d11ce45b7f773832918ec818c9bc3816d1a34dc608fb7f6d102cd22b3b8866b60b2bd98570fdff19d7c00e5c73 SHA512 97692d6ea1a14679557791fb94679e3b72fc64ca41dbffbe43241e40557f5187896b65ecbf6b9598a5bd23890ca4fdfc09c9c9c44f9569c1d91f98a8d00b2865
+EBUILD sxid-4.2-r3.ebuild 884 BLAKE2B 56b8cd14d909a7405a4d2ea8ac1d4b154392143b849a3963fb40d8121817d5ea2d1d1f74705ba6eaa5f044821d7d00d42a180fb3b79da7910d19b93c654b6c76 SHA512 456ad7cf4002cd9f0c2df1ec36ecfacbdd4f06d175ce90894a1af5154d2b7a04404e759507c135505daddfe0572849eebbac796f9908c768e855947e2b653058
MISC metadata.xml 242 BLAKE2B 28b070032e8f2246f59bd293e4532f476be22498928b7cff399446ac31594f29432e4578cbc86750fc92b1c7bdffc040086e60aea5791456cc3a0d41f15cfb51 SHA512 9d92e613111f8de98ea05cc6e64fe1bc2078ddb8838200d4b8068ffd35811dba14125be3023503601539b84ddf3fd41d247a551df7e945da35a26ff33a1d07b9
diff --git a/app-admin/sxid/sxid-4.2-r3.ebuild b/app-admin/sxid/sxid-4.2-r3.ebuild
new file mode 100644
index 000000000000..b62bc5855760
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="https://linukz.org/sxid.shtml https://github.com/taem/sxid"
+SRC_URI="https://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-sxid )
+"
+
+DOCS=( NEWS README docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i 's/bindir/sbindir/g' source/Makefile.in || die
+ sed -i -e 's/configure.in/configure.ac/g' Makefile || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+}