summaryrefslogtreecommitdiff
path: root/app-admin/integrit/integrit-4.2_rc1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /app-admin/integrit/integrit-4.2_rc1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'app-admin/integrit/integrit-4.2_rc1.ebuild')
-rw-r--r--app-admin/integrit/integrit-4.2_rc1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/integrit/integrit-4.2_rc1.ebuild b/app-admin/integrit/integrit-4.2_rc1.ebuild
new file mode 100644
index 000000000000..5e4745ea5cab
--- /dev/null
+++ b/app-admin/integrit/integrit-4.2_rc1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="${PV/_/-}"
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="https://github.com/integrit/integrit/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Tests don't work in 4.2_rc1. Please re-check on version bump!
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.1-fix-build-system.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ mv hashtbl/configure.{in,ac} || die
+
+ eautoreconf
+ touch ar-lib || die #775746
+}
+
+src_compile() {
+ emake
+ emake utils
+
+ emake -C doc
+ emake -C hashtbl hashtest
+}
+
+src_install() {
+ dosbin integrit
+ dolib.a libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ # utils
+ dosbin utils/i-viewdb
+ dobin utils/i-ls
+
+ # hashtbl
+ dolib.a hashtbl/libhashtbl.a
+ doheader hashtbl/hashtbl.h
+ dobin hashtbl/hashtest
+ newdoc hashtbl/README README.hashtbl
+
+ # doc
+ doman doc/{i-ls.1,i-viewdb.1,integrit.1}
+ doinfo doc/integrit.info
+
+ # examples
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}