summaryrefslogtreecommitdiff
path: root/app-admin/integrit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /app-admin/integrit
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'app-admin/integrit')
-rw-r--r--app-admin/integrit/Manifest4
-rw-r--r--app-admin/integrit/integrit-4.2_rc1.ebuild70
-rw-r--r--app-admin/integrit/metadata.xml1
3 files changed, 74 insertions, 1 deletions
diff --git a/app-admin/integrit/Manifest b/app-admin/integrit/Manifest
index 83a96c76cac2..0d43242787d5 100644
--- a/app-admin/integrit/Manifest
+++ b/app-admin/integrit/Manifest
@@ -1,4 +1,6 @@
AUX integrit-4.1-fix-build-system.patch 1169 BLAKE2B 36b13162ea3a583968bda35ece1b4b1cc83871d4c2352ebcbffd079a9265d84b15e72d5e93f10e2404cd26e0622c666cb8b60e1cd53f207f0149a55814e10477 SHA512 4ed15ee8383e280b2d16d353f3401a058ad03c4ad84e4d0932ceec74391e04d266c2468270d2a08d299c57ee105f504c917fcf04b4ac07639bcba42e0fde84f6
DIST integrit-4.1.tar.gz 271626 BLAKE2B 538a34c8e5c00e1be66ba35095be4d61402372ea7fd9ba9bfff9149c9a82c43d625ffb345fe84b7561100b31f2a2a1ba319e8b9a7d2b78e44a81d1ed6ae64f3a SHA512 599ae66a193fd87971994f59422e148e1ae01a5ff0fea93a0f2555c972f5254f0213116950766e72c87a57b1bd490f04afd3e0557d25a366c41dbbacc80b6842
+DIST integrit-4.2_rc1.tar.gz 223627 BLAKE2B ff0dead8a8903dba0f43c7746672ca2d57aced352df2fef7b195fc90e9b38e77bb21affb40c424c5d23df7dcecf3192c1bff5c7c04d3fcbc5dad0dae60565f93 SHA512 2a86a37c684ca0b78bbf7901c8e72511f1169e8af7e9b4efdeadbade52e8fc7302167f6d82bd02b5af9688a05d13fc56d4f5474e3e04d1aef3dd9f72d782d739
EBUILD integrit-4.1-r1.ebuild 1264 BLAKE2B 208f5ff74d53a189f7eabd131e3f032cff73d467e4622d317148d9a17c4b7db55335815ec6e59ba85794794bac1bff901dbd7d21b04e32ea0714fd3c7c54d5f1 SHA512 8cbb22064be0107ae5fa363185ccdecf347e7078a0d455d0af8af59b504282005816c1c52e3a01999568bb39a89e30043c48c556b6e78579c25dbc72afe8a5f4
-MISC metadata.xml 245 BLAKE2B 8edad0fa1051f1c6b28fa61e95cbde797389dcae4a23b953e0b77198a5557e068e09cdb6b2e32ca4e25ea07789c406529094d25fa74182656a4c59f4f7a42178 SHA512 e7052ee3572f1a5546b02087b7de95803a2e8b023aa24bc701eebb0bdd47b294d9634f4e78abfa10764e88397a067b1f1f8e431cddf5f8b260693f56ebd88b8b
+EBUILD integrit-4.2_rc1.ebuild 1405 BLAKE2B f2eb0feefa43b95a8eb43829f12059105fd4605418bc4192fc83bc5012bfd0a250f08ee97245aad6a279aa6c3d9f709081b31bbe7d3ff787523f242ec3e301e7 SHA512 b62825370f9fa3721f9929a2460f1561505e80df1893badabcc2ff83155e7b34e0eb1344fda9312718f184122530f5440d2a8a5c8d36b75caaad09ace5b6b7d5
+MISC metadata.xml 302 BLAKE2B 89b3a92b3cda49f6d17f809f4def559a53fd9f5b9216a5be1468a7e40d83faa78024d9f072fc1ea6c45b50f55675711e0ce93a5f781afd091b3edc738288a5df SHA512 b1fed9677cc00dbe9cdc71f89e3fd99e8c83f4ea7e1a58c192ae3b3b4091df924f93e37c1fac4c02ac0c2c7590e4bf4a9b930716f2181b1ba0d6ff59cc0d1039
diff --git a/app-admin/integrit/integrit-4.2_rc1.ebuild b/app-admin/integrit/integrit-4.2_rc1.ebuild
new file mode 100644
index 000000000000..5e4745ea5cab
--- /dev/null
+++ b/app-admin/integrit/integrit-4.2_rc1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="${PV/_/-}"
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="https://github.com/integrit/integrit/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Tests don't work in 4.2_rc1. Please re-check on version bump!
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.1-fix-build-system.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ mv hashtbl/configure.{in,ac} || die
+
+ eautoreconf
+ touch ar-lib || die #775746
+}
+
+src_compile() {
+ emake
+ emake utils
+
+ emake -C doc
+ emake -C hashtbl hashtest
+}
+
+src_install() {
+ dosbin integrit
+ dolib.a libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ # utils
+ dosbin utils/i-viewdb
+ dobin utils/i-ls
+
+ # hashtbl
+ dolib.a hashtbl/libhashtbl.a
+ doheader hashtbl/hashtbl.h
+ dobin hashtbl/hashtest
+ newdoc hashtbl/README README.hashtbl
+
+ # doc
+ doman doc/{i-ls.1,i-viewdb.1,integrit.1}
+ doinfo doc/integrit.info
+
+ # examples
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}
diff --git a/app-admin/integrit/metadata.xml b/app-admin/integrit/metadata.xml
index fa14c9a7ea90..25b3199e6fdf 100644
--- a/app-admin/integrit/metadata.xml
+++ b/app-admin/integrit/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
+ <remote-id type="github">integrit/integrit</remote-id>
<remote-id type="sourceforge">integrit</remote-id>
</upstream>
</pkgmetadata>