summaryrefslogtreecommitdiff
path: root/app-admin/ansible-molecule
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
commit1c724102ee86c2c9fc156106acc870f69a4764c3 (patch)
tree764c8508307b679f73b5da39393ff9f98a89f2d6 /app-admin/ansible-molecule
parent944021dc3fb629a9c074228bf7da9f7ddf7a0caa (diff)
gentoo auto-resync : 21:09:2022 - 17:26:21
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index d180bcb05564..2f17486e3ecb 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,4 +1,6 @@
AUX ansible-molecule-3.5.2_pyyaml6.patch 225 BLAKE2B 4d7bf726e94ef037bf9bc26bc4ff2f68cc631b9053e532e5ca8a782948c5a3ab127eca68b4a484fde808e2ed48b9b5003eebc0605bbd1caa1b80723e50564870 SHA512 882905ce77fa8ba0cd680d58cdb36da968473260a3543e149b6dad8f04ef28227c5e0684a7ccda15e56dce928146c8ff8441c3c375e680dcbda209325d96b234
+DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
DIST molecule-3.5.2.tar.gz 290964 BLAKE2B b6c6bb8ecdb4230d23161e25fa003c8979f48fc1705bfba7d14204fbaa3e9c235a71db0c4ccbab5c4328ddb8a0725d3c2ba7cb4b624afda21c6453c8be824f3e SHA512 04a7d1f7e7e098c0ada71d8dc9a3e3a94320033942d8ee03f2c51ec185405d2ee13fcb44000a4942ec66923f0426717ab7e2c3a785ddda7a23515096474dc3c3
EBUILD ansible-molecule-3.5.2-r1.ebuild 2952 BLAKE2B 2dc7b3abac3fc5a1381a3927b77b4306ad5f7687be49d93f1a749c229039d4a9f76598cf8d41baf2ffb4ae31b7191a69bd8813228205bab29cd40a4bf1518c20 SHA512 51e36e50568f2681ef4bd28e2a93d1151dcc34c0055e49ad7b9fb2962a26a3bc08d4354d8f6409140d5640126a11d0894e3928da79b5e05cc6c2aef4ac15dca7
+EBUILD ansible-molecule-4.0.1.ebuild 2845 BLAKE2B 7900ccb41af0a1a4d2199a41c140530e6abccb76aec3e17325410f62971637b6ba07d08e0b20110054b2931f065f3599194dd506aa7e350e8bcb77587b00b182 SHA512 d3a6f8256654c06b86a8daada3d8a58af11c6b35777c0e4c830e0fa7b3a2d639850e85800f83f216d71cc528d71996a69d7c5bf8cb95ad95ff69d33d745d9da7
MISC metadata.xml 407 BLAKE2B 869b6c1d6da66568eeac2daaca56567876dbfb057f50add7bbc95fef8a3fc38b99279d359a90573f8d6af47d0e451445827f6efeefa8fb0e7954e8b624783855 SHA512 e6dbbe2c0536ea84bdfea0168a743dbe3de424b442757441bc4f978e07d41ca6022eb2d6f269c921f42b4e7d858788f967c1c35bd4241a35dbe25a161f5744de
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
new file mode 100644
index 000000000000..3e827f95a347
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+MY_PN="${PN#ansible-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
+ doc? (
+ app-admin/ansible-core[${PYTHON_USEDEP}]
+ dev-python/ansible-pygments[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-html-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
+ dev-util/yamllint
+ )
+')"
+
+S="${WORKDIR}"/${MY_P}
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}