summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-21 17:26:21 +0100
commit1c724102ee86c2c9fc156106acc870f69a4764c3 (patch)
tree764c8508307b679f73b5da39393ff9f98a89f2d6 /app-admin
parent944021dc3fb629a9c074228bf7da9f7ddf7a0caa (diff)
gentoo auto-resync : 21:09:2022 - 17:26:21
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin32692 -> 32707 bytes
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild78
-rw-r--r--app-admin/consul/Manifest5
-rw-r--r--app-admin/consul/consul-1.12.5.ebuild2
-rw-r--r--app-admin/consul/consul-1.9.17.ebuild56
-rw-r--r--app-admin/sudo/Manifest2
-rw-r--r--app-admin/sudo/sudo-1.9.11_p3.ebuild2
8 files changed, 84 insertions, 63 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index 7ba2104f4806..2a1f3bf23a87 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index d180bcb05564..2f17486e3ecb 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,4 +1,6 @@
AUX ansible-molecule-3.5.2_pyyaml6.patch 225 BLAKE2B 4d7bf726e94ef037bf9bc26bc4ff2f68cc631b9053e532e5ca8a782948c5a3ab127eca68b4a484fde808e2ed48b9b5003eebc0605bbd1caa1b80723e50564870 SHA512 882905ce77fa8ba0cd680d58cdb36da968473260a3543e149b6dad8f04ef28227c5e0684a7ccda15e56dce928146c8ff8441c3c375e680dcbda209325d96b234
+DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
DIST molecule-3.5.2.tar.gz 290964 BLAKE2B b6c6bb8ecdb4230d23161e25fa003c8979f48fc1705bfba7d14204fbaa3e9c235a71db0c4ccbab5c4328ddb8a0725d3c2ba7cb4b624afda21c6453c8be824f3e SHA512 04a7d1f7e7e098c0ada71d8dc9a3e3a94320033942d8ee03f2c51ec185405d2ee13fcb44000a4942ec66923f0426717ab7e2c3a785ddda7a23515096474dc3c3
EBUILD ansible-molecule-3.5.2-r1.ebuild 2952 BLAKE2B 2dc7b3abac3fc5a1381a3927b77b4306ad5f7687be49d93f1a749c229039d4a9f76598cf8d41baf2ffb4ae31b7191a69bd8813228205bab29cd40a4bf1518c20 SHA512 51e36e50568f2681ef4bd28e2a93d1151dcc34c0055e49ad7b9fb2962a26a3bc08d4354d8f6409140d5640126a11d0894e3928da79b5e05cc6c2aef4ac15dca7
+EBUILD ansible-molecule-4.0.1.ebuild 2845 BLAKE2B 7900ccb41af0a1a4d2199a41c140530e6abccb76aec3e17325410f62971637b6ba07d08e0b20110054b2931f065f3599194dd506aa7e350e8bcb77587b00b182 SHA512 d3a6f8256654c06b86a8daada3d8a58af11c6b35777c0e4c830e0fa7b3a2d639850e85800f83f216d71cc528d71996a69d7c5bf8cb95ad95ff69d33d745d9da7
MISC metadata.xml 407 BLAKE2B 869b6c1d6da66568eeac2daaca56567876dbfb057f50add7bbc95fef8a3fc38b99279d359a90573f8d6af47d0e451445827f6efeefa8fb0e7954e8b624783855 SHA512 e6dbbe2c0536ea84bdfea0168a743dbe3de424b442757441bc4f978e07d41ca6022eb2d6f269c921f42b4e7d858788f967c1c35bd4241a35dbe25a161f5744de
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
new file mode 100644
index 000000000000..3e827f95a347
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+MY_PN="${PN#ansible-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
+ doc? (
+ app-admin/ansible-core[${PYTHON_USEDEP}]
+ dev-python/ansible-pygments[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-html-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
+ dev-util/yamllint
+ )
+')"
+
+S="${WORKDIR}"/${MY_P}
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 9feee8bc54dd..5d7fcc565cf3 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -9,9 +9,6 @@ DIST consul-1.12.5-deps.tar.xz 289550768 BLAKE2B d64d074987dd8abaed5defdfbcab1ff
DIST consul-1.12.5.tar.gz 25159461 BLAKE2B 4e2bdffd77d032037c6999bee0e2ba4ac6c83daee422097f7cec37c74375419336ec50b19abf9b17db9375a9ee69894ad6577499c137945f7f0557d38d6aa4dc SHA512 df735447dae074ac84dc9dbf5bf2e6d907152d233841137fc4ba632bad19b6db49a60cb79473e6432f76c99ac3c1e287be00416a6553eb3acef8b2fcc4c5dcda
DIST consul-1.13.2-deps.tar.xz 252165800 BLAKE2B b954d36ecd06c2aca46eab6680fb31c709f5d05b6645a7d5b042cdd98ae088a1d38fda6e801eede95b32d4c690f59e05161d8a70de0831d8ba47dfa8c529d32c SHA512 4468a11d53cdb9ab70b9286f5b168681d6805401fbdad0f79d02a0a98e869e0c52c098ab90c4ea3291811876444582057efe72c1972b9bb6cbfd13dfda82453b
DIST consul-1.13.2.tar.gz 25412424 BLAKE2B db6b5f86ef73d1273f2657e6d36640f6bf9252a215f914ec4fc7451cce1e3659725fecc1254401223ead034834443df18eaf54155db466e160bc70101944a8cc SHA512 2af6dd62b178aee975a05efd5c5c3b1d763b64226b6e5ff66060ff31e0b7deaba1603bd5fb4507ff48158acb087f1e4190b6b1961cef6a8809aac6a0473d85f9
-DIST consul-1.9.17-deps.tar.xz 214799320 BLAKE2B c9fe5511156d50d4155ed6050186af894b7efc29e2f311ff542f79d298769b2dc55ee1bba12ca5ba5b81eddb6959a1d7a5e55aeb533827d5e924d3a72853a418 SHA512 be9f417e721372b8eaffe8b908f1ca1d1299c897f032cfb8b7ea8b62f7c2689011c5079a450fb5eed2e4e5454f0ad6a5e3859c91bd67166193334d100968f093
-DIST consul-1.9.17.tar.gz 29480703 BLAKE2B c233eab63ea515f886234395100e47910c1acdefa0b29af5bbc96d6c078dae41e0cd4150e1f6f17daac972b3e66d3abe43b594a0c37bff790e43f0f3c0a20da2 SHA512 c859fbede7294884befd0c70469febed5a4269b21cb351f8619d13e3b29f9b8bdd8d18e9611ef34908fc54bd38f2fd0bbc6e96d4e08ab23da952c3db537fb92c
-EBUILD consul-1.12.5.ebuild 1344 BLAKE2B d6b18a9b0c52ec4fbd529c2a776b04ad4c624043fcae3088319ea8a232fa412adff0b1e5cd2fd2ab050527b2d7bc6f6afb39b67ae14a906d1dd957d78293e416 SHA512 8aef82d90f7817c15a0b578582e743c4e7228346558edfe98e2173f80f46cf7a4561bc324c24bd0fb0aa0e4ae006f0d43c868283a8570f1854740d5b179b7c60
+EBUILD consul-1.12.5.ebuild 1343 BLAKE2B ef7ea872ae274fd2703827b70a2e1791e9464a1c03ec05a818abc00e5892329d5875db1e05927f2d81021d2fa1e9a7eb3940b688770c150e7de44a302ffb8741 SHA512 4e6aa3d376fda5f4af8ff2d7b79e4f3f92702f67cb468a0d8ddd288ce3e0b43aa37aac3af59442cfeaf4d0551e02e225f35fe99efd72827dc673ef5433d08fb3
EBUILD consul-1.13.2.ebuild 1450 BLAKE2B db2f1dd22668fc6b338b048bf7c4ec1fbab287f02e05bae78dc4b57325fd8b510491917da88f0c0ac4c0dcb93b3a485e4dee4ba6d6a0c5216ce4e51b177833c1 SHA512 04afd2923652bb85b7d37185269bbed1607cf89c2037057e52bea26ce069beb57815d0e79071f76957725347cfe9e2c23ed31b6e692ee1517995a2b0076b8d16
-EBUILD consul-1.9.17.ebuild 1521 BLAKE2B 4b452b57b8d672d18f3c41b545814b20d0437d190a0439b08579acc5d01f437f1af8411ea4372cc2d4ad3db13f4387c373dae06b6e465ac0becf006f104cb546 SHA512 8edc438a09e02e87b67f1e686fc3ec24921deffc8b577d3239e03dbd78a7f92f9a2da04f65234f2563c55eff3fabc8e844e7f165dc36f5bfc4f66cbfbc68576f
MISC metadata.xml 392 BLAKE2B 4995d973307987bb70802d4328dbb1d5e052683a2e1900912b40be5e345969740b1df9e8e1b3bcbf76fb90066ed43ac5ce91e8e11a0ad19c9d587c7204f45419 SHA512 92d4589b5294df0ddcee6fbafa5db5288b3e892dbec6d84bf0e53beb2b0a30e385f9166c536462e51aeaa9ee8799dd1ae3634b7b13e452e3059ba2853c5b77f1
diff --git a/app-admin/consul/consul-1.12.5.ebuild b/app-admin/consul/consul-1.12.5.ebuild
index 62d10cef792d..62a5094a5777 100644
--- a/app-admin/consul/consul-1.12.5.ebuild
+++ b/app-admin/consul/consul-1.12.5.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
RESTRICT+=" test"
SLOT="0"
-KEYWORDS="~amd64 ~arm64"
+KEYWORDS="amd64 ~arm64"
BDEPEND="dev-go/gox"
COMMON_DEPEND="
diff --git a/app-admin/consul/consul-1.9.17.ebuild b/app-admin/consul/consul-1.9.17.ebuild
deleted file mode 100644
index 79da67e99b66..000000000000
--- a/app-admin/consul/consul-1.9.17.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-
-SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT+=" test"
-SLOT="0"
-KEYWORDS="amd64"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-src_compile() {
- local git_commit
- git_commit=$(grep '^[[:space:]]*gitCommit[[:space:]]' vendor/k8s.io/client-go/pkg/version/base.go)
- git_commit=${git_commit#*\"}
- git_commit=${git_commit%\"*}
- [[ ${git_commit} ]] || die "failed to determine gitCommit"
-
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${git_commit}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}
diff --git a/app-admin/sudo/Manifest b/app-admin/sudo/Manifest
index 2b876b3e0537..7e4d4b8cf0b1 100644
--- a/app-admin/sudo/Manifest
+++ b/app-admin/sudo/Manifest
@@ -6,6 +6,6 @@ DIST sudo-1.9.11p3.tar.gz 4826520 BLAKE2B f8508f65b514abd9979a11628d8bc0e085b262
DIST sudo-1.9.11p3.tar.gz.sig 566 BLAKE2B 8caf03b051222f0446eaf333b48563aa18d52acbd9f7e2d880f0a97043df1ec8d25d87cfd7b1b9543ab8f52f5dacff4cf031fe3e6b94593d576d1d351eb05aa4 SHA512 ea728cddbab50746a2cbb8ce6cb55df3def1c5e806a1d91ec6f2d65c8d246079bdb5799b961ab0da1cc2c347a36d93cc00d32c10856141a467b25e1224876e50
EBUILD sudo-1.9.10-r1.ebuild 6976 BLAKE2B 8319a74c6c4cd73c1c45b2d28c5275fa1d6438a67a198541c9202f1081c9d0d7a53b87e4669ac48e6d3cf1ebfff5c4b06e14bbe08854166e4f9205e784ca441c SHA512 239152e2442735957d4d11e35a28a738a8a84024f4453202dc2465c59da46561642d98927ddb0c4ea9b879688605e6fe3d94b9c05399d42157002d2a6be5e488
EBUILD sudo-1.9.11_p2.ebuild 7386 BLAKE2B ccae805ca97cc7470605997171bd5d9a292a2dd094b78ba834b34cc0c1c608b228f66c3c5329641532fda23e5dd32f867363fd1edc5106bd7a04d01c3947929b SHA512 d5596e4c9e7e2ad5af160575c0daf27573a6704830f46add107eaab1a7002a36ac364ee758fb976db3ed74a88b5f910f25107225b050eb72c5282300cdc58b94
-EBUILD sudo-1.9.11_p3.ebuild 7379 BLAKE2B cc23184ffde0b1c4ab89d359ed717e3d141d7cbda37e6a92bd809986e3df7a79e5e4b17016a1a1118ef44468678e9a2d09c1132fa1b63aade2b9a4876dbcfb53 SHA512 d406d45b7f11a6b77c828658722757b55bb7e301f0b992665196c08f6ba7c950433499999b408f556eb8478d3afb14d718ed43b5acadcbcb5a7095c73fd10ad0
+EBUILD sudo-1.9.11_p3.ebuild 7378 BLAKE2B aaa0198387f15661dea00224e12cf8e46e0f60c7117a9363c01e1d793ad23a520fe5cb2d0a03f5e5a80db481d3451c61e8f651b23ee65844e90ec8bd37ba95a4 SHA512 5050a1c680fdcb4d6ad919abe3b92563e514ea65903b09693e4bfa8bef15a99f501ce7f57347bacc9073d86413e9ddd08ae7f0ef758b6959ba810830049e6753
EBUILD sudo-9999.ebuild 7386 BLAKE2B ccae805ca97cc7470605997171bd5d9a292a2dd094b78ba834b34cc0c1c608b228f66c3c5329641532fda23e5dd32f867363fd1edc5106bd7a04d01c3947929b SHA512 d5596e4c9e7e2ad5af160575c0daf27573a6704830f46add107eaab1a7002a36ac364ee758fb976db3ed74a88b5f910f25107225b050eb72c5282300cdc58b94
MISC metadata.xml 1107 BLAKE2B a18b1d280445ea98ba686021abf08ab47a5ac590795018c125008f2a8e44f7ea45e256e32a737781030960cb984bc16d8fd23175fd1e88b294e5036c86085367 SHA512 8cacbd9a1a23fc7734c5ad8b95c769b8506ec35490b5e3f69439bf71bd51d1eaf04fe699a82cbb3ac56182195fff570d75e3b20c33d86774480a2939122752a6
diff --git a/app-admin/sudo/sudo-1.9.11_p3.ebuild b/app-admin/sudo/sudo-1.9.11_p3.ebuild
index bee2855926e4..40273e0501e8 100644
--- a/app-admin/sudo/sudo-1.9.11_p3.ebuild
+++ b/app-admin/sudo/sudo-1.9.11_p3.ebuild
@@ -29,7 +29,7 @@ else
ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz.sig
)"
if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~sparc-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~sparc-solaris"
fi
BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-sudo )"