summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 03:07:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 03:07:52 +0000
commit543ec4dd8d83d1bffd29eb10fa993dffb888ba81 (patch)
treea953f8cca9126188dddb9b6eca9a82b8b8c72c7c /app-portage
parent0244142efc86407fe20174884a32027fcd732a96 (diff)
app-portage/sisyphus{,-qt} : adjust to the new EAPI
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-4.2212.0-r3.ebuild4
-rw-r--r--app-portage/sisyphus/sisyphus-4.2212.0-r3.ebuild12
2 files changed, 8 insertions, 8 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-4.2212.0-r3.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-4.2212.0-r3.ebuild
index 56372e84..cafae76c 100644
--- a/app-portage/sisyphus-qt/sisyphus-qt-4.2212.0-r3.ebuild
+++ b/app-portage/sisyphus-qt/sisyphus-qt-4.2212.0-r3.ebuild
@@ -30,9 +30,9 @@ RDEPEND="${DEPEND}
')"
src_install() {
- emake DESTDIR="${D}" install-gui
+ emake DESTDIR="${D}"/ install-gui
# enforce the best available python implementation (CLI)
python_setup
- python_fix_shebang "${ED}"usr/share/"${MY_PN}"/"${MY_PN}"-gui.py
+ python_fix_shebang "${ED}"/usr/share/"${MY_PN}"/"${MY_PN}"-gui.py
}
diff --git a/app-portage/sisyphus/sisyphus-4.2212.0-r3.ebuild b/app-portage/sisyphus/sisyphus-4.2212.0-r3.ebuild
index 84ea6f9f..5f1340c7 100644
--- a/app-portage/sisyphus/sisyphus-4.2212.0-r3.ebuild
+++ b/app-portage/sisyphus/sisyphus-4.2212.0-r3.ebuild
@@ -36,7 +36,7 @@ RDEPEND="${DEPEND}
PDEPEND="qt5? ( ~app-portage/${PN}-qt-${PV} )"
src_install() {
- emake DESTDIR="${D}" install-cli
+ emake DESTDIR="${D}"/ install-cli
python_moduleinto "$(python_get_sitedir)"/"${PN}"
python_domodule src/backend/*.py
@@ -60,19 +60,19 @@ src_install() {
# enforce the best available python implementation (CLI)
python_setup
- python_fix_shebang "${ED}"usr/share/"${PN}"/"${PN}"-cli.py
+ python_fix_shebang "${ED}"/usr/share/"${PN}"/"${PN}"-cli.py
}
pkg_postinst() {
# Take care of the etc-update for the user
- rm -rf "${EROOT}"etc/"${PN}"/._cfg*
+ rm -rf "${EROOT}"/etc/"${PN}"/._cfg*
# Make sure portage sees the new mirror configuration file
- rm -rf "{EROOT}"etc/"${PN}"/mirrors.conf
+ rm -rf "{EROOT}"/etc/"${PN}"/mirrors.conf
if [[ $(uname -m) == "x86_64" ]] ; then
- ln -sf "${EROOT}"etc/"${PN}"/"${PN}"-mirrors-amd64.conf "${EROOT}"etc/"${PN}"/mirrors.conf
+ ln -sf "${EROOT}"/etc/"${PN}"/"${PN}"-mirrors-amd64.conf "${EROOT}"/etc/"${PN}"/mirrors.conf
elif [[ $(uname -m) == "aarch64" ]] ; then
- ln -sf "${EROOT}"etc/"${PN}"/"${PN}"-mirrors-arm64.conf "${EROOT}"etc/"${PN}"/mirrors.conf
+ ln -sf "${EROOT}"/etc/"${PN}"/"${PN}"-mirrors-arm64.conf "${EROOT}"/etc/"${PN}"/mirrors.conf
fi
}