summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
index 2f57d6b05358..530eae19a64a 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
@@ -6,7 +6,7 @@ EAPI=7
inherit cmake-utils xdg-utils
DESCRIPTION="Alternate application launcher for Xfce"
-HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -31,6 +31,13 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ # fix build failure w/ xfce4-panel-4.15.0
+ sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
+ panel-plugin/register-plugin.c || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_AS_NEEDED=OFF