summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-hdaps
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-hdaps')
-rw-r--r--xfce-extra/xfce4-hdaps/Manifest1
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/Manifest b/xfce-extra/xfce4-hdaps/Manifest
index 205ee7a3f4b7..4bb907656528 100644
--- a/xfce-extra/xfce4-hdaps/Manifest
+++ b/xfce-extra/xfce4-hdaps/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-hdaps-1.0.3.tar.xz 350936 BLAKE2B 37d80bafa831be68b55f66c029ec120b67ea1a21760291f05cf11587161b295698a5994df3abb9eaa2c3ff94af7b0f43a3cfd04cef31993d741918b4eb7e8f49 SHA512 9263a6d63b4e4cd9729a87ae5150d10a6ef3a2bde48b5a82334e948d884869ed2492953eaef4df08b6a2155454ef81af6b83e70f1436cfaca4f2fd8e39b5ac34
+EBUILD xfce4-hdaps-1.0.3-r1.ebuild 822 BLAKE2B 0c335fe0024352bd005c68965bba0eaaf11ecba59b8607248f76b95becd2e56ccdbafd269c11edc7cb6613420b311fe94392a6cb34047ea2410fc7d72e4d87d6 SHA512 f0f3a6e7ed776ce837291cde54c356954e604ad3948607d7f6b46aecbdcc11f2e2cefc335276a77ce38364411a52809c631c51655683213af7078ac1c08b7071
EBUILD xfce4-hdaps-1.0.3.ebuild 814 BLAKE2B 6e3e8a6122fe354b9f94a1fbd6ba4a39f00084797cd1e2ecc34c4e8d509bc3a2f2868c2742f406995cffaecdb7e4345496d3b52b90a52325ca0b8b790a192734 SHA512 6293955fd7ef507cda05c55388dca10dc150595ab19d312d5f20f1267fda5d1f54442652ae0db506e36d6f172b7a55cb045b862af23f292097d329995f0ddd30
MISC metadata.xml 361 BLAKE2B 5cd2add88280a250320d9cddf426824cfe890a02b933c25007419c293c0d8550419220d078310c971f80c0bbbd6799a24abbcead8f04e970980c1a8150290bf5 SHA512 c06790d6a518af011bb7cc31ddc75754de480e5a6a0726ba5dba4f728f210dbc85342a6228a398fa1452424b61cfb1b1ced19dd5fc3c8a4c3664a7411eb77267
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..64f82e508edd
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="https://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}