summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpugraph-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.5-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index d60abcff4bdb..5e1c5fbc0e44 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-cpugraph-plugin-1.0.5.tar.bz2 328972 BLAKE2B 7c39aa6fd9d0d6ecc5bedce1d99d330765c329d1fa673b61282fdea654ebd997caa118f57dd0776008584eaa2dbe0a6ae7df532ed3b941b03b111f5ae753d2e8 SHA512 3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a
+EBUILD xfce4-cpugraph-plugin-1.0.5-r1.ebuild 811 BLAKE2B a648612cefd8aabbb477d85d1b1724a4fb2f365575e298abb79a0ea0651bd672dcae32cbb2a1adbf600f2d5bc92a8540d0e60ba5515309a44ab8c9ab5e07e4bc SHA512 ba398a44b42b945903fa8e50b3267af1e0909cc4106a89007ea747224a3ef4de3c109437ad018ee58b5f7072ae3ae19967d01f7a81b29d9df14b4728c9b7d7f4
EBUILD xfce4-cpugraph-plugin-1.0.5.ebuild 748 BLAKE2B 8075f3c581d656598b828aa8195b713ad3311fb2a726c3749c221967e575d99cd601eec0989cc6c4106c98019be57983df03d98f6eea9c7a66fdc1e4494a35b7 SHA512 9d8b7c0fa8af1230f94dd84c5572ba2ab71ed30c799abcc12bda4fcde87d79b839f8881535fbff2084b8f4caae6e933aa67188faccd9d39acd84d8ab7a366f62
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.5-r1.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..68b09902c873
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}