summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-clipman-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.7.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 597941a47f4d..1e77db7d99f0 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-clipman-plugin-1.6.6.tar.bz2 487832 BLAKE2B 4d27c06c71c978680a2785db67262196293f1692fd82ba9cfdc2810b021dc83d8778243801e0766741e8f194a5aaa0573d5548443f6c3bfc9f7b970d7f102446 SHA512 4f6bb8f56111903af576d06ce5883e8ada2cb3ea377e09a79d2c5fb6f37743dac621649465a573a8a29a1fb884e7608a53dd6486eada23c7f8ee6401237988af
+DIST xfce4-clipman-plugin-1.6.7.tar.bz2 637572 BLAKE2B 72220f5e5c1460608be8ae9800ccefc74daa17634dcf79b014f92529e7c836bc9772830e04e182de1a69803ed18d355a7a1489012fb3a6b6b3c4aaa9db820800 SHA512 0616ee8366952cf90ea60887d7c0081b4fc3b2a80cb8f3613e294ea1086477c30a820b688045e49ec4787042a83964732e85a458acf1997c1a7ea244dd225892
EBUILD xfce4-clipman-plugin-1.6.6.ebuild 1418 BLAKE2B c9ce082ff164831d8faae8cab5a4217f4773eb0a7698475e143ff45179ce9bbcf1ad4f7f4dcf644f110c30b4acecd017429b3bb07618eb7f0a95bfb7bab99a4e SHA512 58876e7ccc732b8de65deccef266ddc1a0c7a1001bcff21fe4487c4178b99c97879e292ffb99284f0e98d8e352a9bf338fb350898ca934485b4c662ac6aee186
+EBUILD xfce4-clipman-plugin-1.6.7.ebuild 1413 BLAKE2B f7d6f6ecd09e0a5d8cfff27ba2a01be78a57d6a98a9a1f6574550bc8e4db54b959f44a0e248daa83655d20afba741183a8f26ab50e48bffdab590da7ffc07936 SHA512 6932a248589555d8ed948bd6b7588f988274b453e28e9d2f0b2654abb3df9c3c9ad544cde366e73f785d4b44c3f8ebfe80fd9e978983b3352752603e3aa0a016
MISC metadata.xml 345 BLAKE2B 2a84642f72b32862062e911bc3d9495d77cde305206e3ba0d0bc82c792450506696d02e45b59d5035278bf53061016c72de278586e7669d53899c4d3c86585fe SHA512 0dbb04321b8dedc5bdfd3e7714cdbb3021ec1c866fcc61613081282c32316af6598e1516b629c6c6560a509abb0e6f378c0089dca1425b6c82ab796d5875a693
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.7.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.7.ebuild
new file mode 100644
index 000000000000..5c08fcd468d5
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X qrcode wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+DEPEND="
+ >=dev-libs/glib-2.60.0
+ >=x11-libs/gtk+-3.22.29:3[wayland?,X?]
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXtst-1.0.0
+ )
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+ wayland? (
+ >=dev-libs/wayland-1.15.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ X? (
+ >=x11-base/xorg-proto-7.0.0
+ )
+ wayland? (
+ >=dev-util/wayland-scanner-1.15.0
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}