summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-archive-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest2
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index bf073926fea1..8d47ed359b4f 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1,3 +1,5 @@
DIST thunar-archive-plugin-0.5.2.tar.bz2 371599 BLAKE2B a32e0d7c42ad075d2f40d815ca74b86bb0a9a3a2db8c4e2146d3e90b12d7ba4e72b7f75703adcc6aeca702b1124cbe833e80def9891498056c8e0c0483318cab SHA512 f334b960c623bc6c5736ba38d0e965b4e8d4f22fe857a66301c36c255701a702f839d6f63f67b37bc665066d75d787ea8159d4eed7561a2ecd98340bdcb65bc0
+DIST thunar-archive-plugin-0.5.3.tar.bz2 444382 BLAKE2B 08c78f8a94a2cb2b752e8e929a128dd8a7da4d22913c91ed4d9537b81f7a8732178294cabc805abf5f7127bb97caa651776c42d721d086f64ecb51614a9174ad SHA512 941af6925baee02b12e4f9424ad6f3a23175eab96e0fc8cf65456d8015d7912d5049956910047fb292294fe73311819d36028b25954c30c8a0377eccdb62c75a
EBUILD thunar-archive-plugin-0.5.2.ebuild 897 BLAKE2B bbe3f8fe02cc7ec735130b8ceea131e5a0cb12a196056af66f9bd5bed68aab6be2db8e3381910d5c1a04f45512600fb74bd4a3ff779c6051a9f08c0d0d8e216f SHA512 aa49d33e51619147ae96fa0587f17614f6e21baa135414be0e859be4b66c68e129284baacce3ef724d0322197b1208843308b935f5e8f1f76e501b8c1352a9fc
+EBUILD thunar-archive-plugin-0.5.3.ebuild 892 BLAKE2B 2ddc4428374c77f2e54f768e00894ffc5a7f01e9ff678835bdc6c4cf68201729601ae37392bdb295613f5ab91be0afe038d53dc8841e1a755279920f4a17173c SHA512 cef9081f3854ac2121b3f0917f6559fcdf6726f581cebd7f60330674e59e676708fc67a59e0beab4a1fc3be2554abcfa42130c3d700b0c34c21eb2ad7e480f7a
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild
new file mode 100644
index 000000000000..ae120e6c181d
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/archive
+ https://gitlab.xfce.org/thunar-plugins/thunar-archive-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}