summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-settings
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/Manifest2
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.18.5.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 78f6b1f75ae6..313625a526c2 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,5 +1,7 @@
DIST xfce4-settings-4.18.4.tar.bz2 1557097 BLAKE2B 0269ed1778becc547ba187c096d7c9938cc00f56fb1c9312c9d0eb9b5344d4785f88abadecf391724699de2cb28b35ffed057f06e85f3e098a902a4047969a9c SHA512 2f9e2de4a3a0cc59b4701b44899464532fbae8805270485d2821b65b9d78be54bb636c4cd4205de97e18c13b20912fcd1f4ca0b3baa561bf1a783829f53a06a0
+DIST xfce4-settings-4.18.5.tar.bz2 1559812 BLAKE2B 3639cb17dbe9311556de03f5ae497ab7b18fa170e64cfab2c414194bb544b370a2d82df0344a859b4b0b7438dc1e0046b5e8519206553decbf8bf3def5534503 SHA512 706407131bf4c78d5b5a7604444c76b4c8e84444d48ca145d9934b3e2facc9117762ac3f05ef54ea0275b80d96ab54a0a174f1799f949710c436744fe42dcabd
DIST xfce4-settings-4.19.2.tar.bz2 2433368 BLAKE2B 00175d94837c0abec841feed5d1ea834160afccae8718f4af11323d65d5d751d288dd2651b06ceee6ec02fa2ec222e5b94322a38fa59fd29a18e64a1eb84c88c SHA512 dc225dc3d4296db1dbfdd93685a29b453faab2c3259e2dd1f162d631b3853c4f2b582facab60814d1babe934c2eac752ef954dff2b285e9340dd5247f131555a
EBUILD xfce4-settings-4.18.4-r1.ebuild 1875 BLAKE2B e743f6decff07236aa38f24ca1264dafad20ce526cc6654f818476f91d327def0aaa9af7304a697ddcdeaad2ff3dacd9ccc9d0f10c0a24dcc951d6872cb0cf01 SHA512 97520f70bc977ec834eb65a33d31e68b03eefad57e09eb329744722ccbdb09bcca7ace2bbc660c9b045adccd6e8de649baed4392da9bbcd7bb03717b5e15d78f
+EBUILD xfce4-settings-4.18.5.ebuild 1881 BLAKE2B 1cb8302ec338f325c86bcc98a535403987c357efc8e441e3cb062e1bbf4eed591879a3a014ee42f1abd734318d0046aee28756364d7a89d7424bae070cb79861 SHA512 1493baab9a94db1e8e590c37eb829d6db72757c49e80d1e42e137ec7796bd71c4fd2b8385aa14ce0c7183d39fc619f4a4c3355259353b0d7505cb50e847c61b8
EBUILD xfce4-settings-4.19.2-r1.ebuild 2240 BLAKE2B b448b6f7c99c93fd2ebcd40f587b8b9acbc2a6f650ad5e07a2eb8d3413f3c5737ad2038d3661aacd9e034eccd5663c619a106bf1877cfc1a66f2b7975b1af525 SHA512 e72ca39c41d08cba11e2c9a22f7dc2f30df79a06b02308e54da44838444370b7a44a8fb945d6a8a65fd342779f42373b24d54289679ddb3dcca23a41bb1095c4
MISC metadata.xml 480 BLAKE2B 4aabe2bbd7da19f62794843c890648503139a81904d84f6b97f9af9634a43ad583eede1adec9704969663455d033838db3a9a825c90d6f341cea411ed89514f2 SHA512 7e1e28f50387533611b4cee185e5e91b1dcc180ebb5bf7bcbd5fa58bc8ef666ce1bba57961de19016ceaa75a6b60b70ec55cff9a2d22bdf0d4f2b9e04abf2bb7
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.18.5.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.18.5.ebuild
new file mode 100644
index 000000000000..bca7a8b05d91
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.18.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-settings/start
+ https://gitlab.xfce.org/xfce/xfce4-settings/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.66.0
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.24.0:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/exo-4.15.1:=
+ >=xfce-base/libxfce4ui-4.17.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.13:=
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ default
+ python_fix_shebang dialogs/mime-settings/helpers/xfce4-compose-mail
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}