summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild')
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild
index 5f2eb5cf173a..d2f2822092c8 100644
--- a/xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.19.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit python-single-r1 xdg-utils
+inherit autotools python-single-r1 xdg-utils
DESCRIPTION="Configuration system for the Xfce desktop environment"
HOMEPAGE="
@@ -63,6 +63,17 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ # https://bugs.gentoo.org/913864
+ # https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/494
+ "${FILESDIR}"/${PN}-4.19.1-gmodule-libs.patch
+)
+
+src_prepare() {
+ default
+ eautomake
+}
+
src_configure() {
local myconf=(
$(use_enable upower upower-glib)