summaryrefslogtreecommitdiff
path: root/xfce-base/exo/exo-4.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/exo/exo-4.17.1.ebuild')
-rw-r--r--xfce-base/exo/exo-4.17.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-base/exo/exo-4.17.1.ebuild b/xfce-base/exo/exo-4.17.1.ebuild
new file mode 100644
index 000000000000..0afdec17d30d
--- /dev/null
+++ b/xfce-base/exo/exo-4.17.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}