summaryrefslogtreecommitdiff
path: root/x11-wm/xpra/xpra-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xpra/xpra-3.0.2.ebuild')
-rw-r--r--x11-wm/xpra/xpra-3.0.2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-wm/xpra/xpra-3.0.2.ebuild b/x11-wm/xpra/xpra-3.0.2.ebuild
index f3cb1bc10dec..2d11aede8cae 100644
--- a/x11-wm/xpra/xpra-3.0.2.ebuild
+++ b/x11-wm/xpra/xpra-3.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,6 +25,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
COMMON_DEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXdamage
@@ -66,7 +67,6 @@ RDEPEND="${COMMON_DEPEND}
dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
virtual/ssh
x11-apps/xmodmap
- x11-libs/gtk+:3[introspection]
cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
@@ -86,8 +86,11 @@ DEPEND="${COMMON_DEPEND}
RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
- "${FILESDIR}"/${PN}-2.0-suid-warning.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
+ "${FILESDIR}"/${PN}-2.0-suid-warning.patch
+ "${FILESDIR}"/${PN}-3.0.2-ldconfig.patch
+)
pkg_postinst() {
enewgroup ${PN}
@@ -151,9 +154,3 @@ python_configure_all() {
export XPRA_SOCKET_DIRS="${EPREFIX}/run/xpra"
}
-
-src_compile() {
- # xpra calls `ldconfig -p` during compile to locate libraries.
- addpredict /etc
- distutils-r1_src_compile
-}