summaryrefslogtreecommitdiff
path: root/x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch')
-rw-r--r--x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch b/x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch
new file mode 100644
index 000000000000..537e9f6d6e46
--- /dev/null
+++ b/x11-wm/spectrwm/files/spectrwm-3.5.0-fix-cflags-ldflags.patch
@@ -0,0 +1,26 @@
+diff --git a/linux/Makefile b/linux/Makefile
+index e49cb2b..5e2a01b 100644
+--- a/linux/Makefile
++++ b/linux/Makefile
+@@ -12,16 +12,16 @@ BUILDVERSION := $(shell sh $(CURDIR)/../buildver.sh)
+ LIBVERSION := $(shell . $(CURDIR)/../lib/shlib_version; echo $$major.$$minor)
+ LIBMAJORVERSION := $(shell . $(CURDIR)/../lib/shlib_version; echo $$major)
+
+-MAINT_CFLAGS := -std=c99 -Wmissing-prototypes -Wall -Wextra -Wshadow -g
+-MAINT_LDFLAGS := -Wl,--as-needed
++MAINT_CFLAGS := -std=c99 -Wmissing-prototypes -Wall -Wextra -Wshadow
++MAINT_LDFLAGS :=
+ MAINT_CPPFLAGS := -I. -D_GNU_SOURCE -DSWM_LIB=\"$(LIBDIR)/libswmhack.so.$(LIBVERSION)\"
+
+ ifneq ("${BUILDVERSION}", "")
+ MAINT_CPPFLAGS += -DSPECTRWM_BUILDSTR=\"$(BUILDVERSION)\"
+ endif
+
+-BIN_CFLAGS := -fPIE
+-BIN_LDFLAGS := -fPIE -pie
++BIN_CFLAGS :=
++BIN_LDFLAGS :=
+ BIN_CPPFLAGS := $(shell $(PKG_CONFIG) --cflags x11 x11-xcb xcb-icccm xcb-keysyms xcb-randr xcb-util xcb-xinput xcb-xtest xcursor fontconfig xft)
+ BIN_LDLIBS := $(shell $(PKG_CONFIG) --libs x11 x11-xcb xcb-icccm xcb-keysyms xcb-randr xcb-util xcb-xinput xcb-xtest xcursor fontconfig xft)
+ LIB_CFLAGS := -fPIC
+