summaryrefslogtreecommitdiff
path: root/x11-wm/openbox/openbox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-9999.ebuild')
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index fd29dcff8e5e..a2cb088ec10b 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit multilib autotools python-r1 eutils
@@ -9,10 +9,12 @@ inherit multilib autotools python-r1 eutils
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager"
HOMEPAGE="http://openbox.org/"
if [[ ${PV} == *9999* ]]; then
- inherit git-r3
+ inherit git-2
EGIT_REPO_URI="git://git.openbox.org/dana/openbox"
SRC_URI="branding? (
https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
+ KEYWORDS=""
+
else
SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz
branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
@@ -27,10 +29,6 @@ REQUIRED_USE="xdg? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="dev-libs/glib:2
>=dev-libs/libxml2-2.0
>=media-libs/fontconfig-2
- x11-libs/cairo
- x11-libs/libXau
- x11-libs/libXcursor
- x11-libs/libXext
x11-libs/libXft
x11-libs/libXinerama
x11-libs/libXrandr
@@ -49,14 +47,21 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto"
-PATCHES=( "${FILESDIR}/${PN}-3.5.2-gnome-session.patch" )
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
+}
src_prepare() {
- default
+ use xdg && python_export_best
+ epatch "${FILESDIR}"/${PN}-3.5.2-gnome-session.patch
sed -i \
-e "s:-O0 -ggdb ::" \
- -e 's/-fno-strict-aliasing//' \
"${S}"/m4/openbox.m4 || die
+ epatch_user
eautoreconf
}