summaryrefslogtreecommitdiff
path: root/x11-wm/muffin
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/muffin')
-rw-r--r--x11-wm/muffin/Manifest2
-rw-r--r--x11-wm/muffin/files/38919a88b2b8381f5b24b69742d1b9db32029c61.patch23
-rw-r--r--x11-wm/muffin/muffin-6.0.1-r2.ebuild184
3 files changed, 209 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index ea54bd2d7337..4c61dba97414 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1,5 +1,7 @@
+AUX 38919a88b2b8381f5b24b69742d1b9db32029c61.patch 724 BLAKE2B aa7739b0e333d887b39e89f7774b016b6aa9339b37682861f852d354554ccdbe52cc9c9bc50bb612731e4f9a371b749729758d9ab8072ab0d5f282f46c4c697f SHA512 5f96534e613356453a9e060c0145d55db3737812e5094568819c031ced6e2c8c41583ac208b38a664d42302cb94031d20154764628cae05348d20362b91d0ffe
DIST muffin-5.8.1.tar.gz 4519174 BLAKE2B 29269c641e28117f9dd0900dc129aca21c8834058e6b3168b2d44e0ecafba0b177ba214c82337f3120512f4433d6117781685f422a57a244edbfa8748a5ae661 SHA512 bf8e5cdc789ac8a2d1f616a751bf321209b13e3936b483d46370017c58a4b9ebd10b42a71e8691a42f013a0c44250e4a84549d9c5cf120d3382f61aa6040710b
DIST muffin-6.0.1.tar.gz 4521556 BLAKE2B e3f28dea9f66b30805f9b98bc79f2e4a08e9e5eb6501f455f0e3c42c5d9ed14c48be75b07a97da7b671156d14ed61f3b882d8ede4f9b83dac5496fac5a0f0348 SHA512 94aa767db3677116094cb0d9a63d1a446b6ec426b4b38576fcdb17259ef92d81f1a14c0e93dadd2bc4dfaca522531ed177bb0af895b3df7abf20d0e9a77d71af
EBUILD muffin-5.8.1.ebuild 3076 BLAKE2B 3deaa21d00b8cb78f8d7c29325f683e67ba8f3c5fdd0e49a7106765ec1710f59468dada59db1b96cd9d0e8b51d986ff27eb096c5b08d0db883d717cce7427b65 SHA512 7a3c6409c4b915c42a2b67f11426e5be6762365346093e9ba99b36d4f69279156e05cf1c04a62c5a44205e13bddaeb8adea5203cd32040a3b9c06e46c98612f5
EBUILD muffin-6.0.1-r1.ebuild 4101 BLAKE2B d7629f62e5888b83c2df2ea0f87cc929e46836adee876ac773b8ccc3c1645b2d3ceec97069b9d6a0b1d3527277fb29b1427db50cc011201301bb47b281302a6d SHA512 d7532f2f7f15cf1bd780f3a1070400f8cdcfb661cd832f412538124e243ee63c2ec82c850a65b1bab550916d472a1d4f5cb92a98b9f62869490be630e0319477
+EBUILD muffin-6.0.1-r2.ebuild 4298 BLAKE2B 8d1753626944a825bb85e98eeb30548a1a2f1ef0a4cfb7a0357ab4d2dc80279c1082bbe494a155100e42f585fc1ca1e53575caf0d7a29b9ebfcbc3b6f634165f SHA512 6d7a065e9a3d6f40a4443d76d7e7759772c149f5cd530a12ec11c712533a7da99db5c49a026e982b10205a90a724e39b8af77294935d58b9ee6351b524472e32
MISC metadata.xml 611 BLAKE2B 550f115a51852c3e1dfcb9f84bd84c6c24fcfa7b90ca3772ed1e7e315a7b112c035e17a34e029e794922012eee3163759fc6105af29e0dfd1767183c4779005c SHA512 3211657912916ca3a207f46159d436839e9a82594cdad574dc02c64b19654f801e082284d56c4dceddd8cdbb8be424f0b4be37b010f3130551dfe12df2928ecf
diff --git a/x11-wm/muffin/files/38919a88b2b8381f5b24b69742d1b9db32029c61.patch b/x11-wm/muffin/files/38919a88b2b8381f5b24b69742d1b9db32029c61.patch
new file mode 100644
index 000000000000..a2472ec9f212
--- /dev/null
+++ b/x11-wm/muffin/files/38919a88b2b8381f5b24b69742d1b9db32029c61.patch
@@ -0,0 +1,23 @@
+From 38919a88b2b8381f5b24b69742d1b9db32029c61 Mon Sep 17 00:00:00 2001
+From: Leigh Scott <leigh123linux@fedoraproject.org>
+Date: Mon, 5 Feb 2024 16:06:14 +0000
+Subject: [PATCH] Fix compile issue (#683)
+
+(warning becomes an error due to gcc 14 changes.)
+---
+ src/core/prefs.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/prefs.c b/src/core/prefs.c
+index c07359abc..3161e4be9 100644
+--- a/src/core/prefs.c
++++ b/src/core/prefs.c
+@@ -2258,7 +2258,7 @@ meta_prefs_add_keybinding (const char *name,
+ }
+ else
+ {
+- strokes = g_strdupv (bindings);
++ strokes = g_strdupv((gchar **)bindings);
+ }
+
+ queue_changed (META_PREF_KEYBINDINGS);
diff --git a/x11-wm/muffin/muffin-6.0.1-r2.ebuild b/x11-wm/muffin/muffin-6.0.1-r2.ebuild
new file mode 100644
index 000000000000..d3f1afc4229f
--- /dev/null
+++ b/x11-wm/muffin/muffin-6.0.1-r2.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils meson python-any-r1 virtualx
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/muffin"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+ MIT SGI-B-2.0"
+SLOT="0"
+IUSE="input_devices_wacom +introspection screencast sysprof systemd test udev wayland video_cards_nvidia"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+REQUIRED_USE="wayland? ( udev )"
+
+# Dependencies listed in meson order
+COMDEPEND="
+ x11-libs/libX11
+ >=media-libs/graphene-1.9.3[introspection?]
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/pango-1.20.0[introspection?]
+ >=x11-libs/cairo-1.10.0[X]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.61.1:2
+ >=dev-libs/json-glib-0.12.0[introspection?]
+ >=gnome-extra/cinnamon-desktop-5.8:0=
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-libs/libXrender
+ >=x11-libs/libXrandr-1.5.0
+ x11-libs/libxcb:=
+ x11-libs/libXinerama
+ x11-libs/libXau
+ x11-libs/libICE
+ >=app-accessibility/at-spi2-core-2.46.0:2[introspection?]
+ >=media-libs/libcanberra-0.26
+ sys-apps/dbus
+ media-libs/libglvnd[X]
+ media-libs/mesa[X(+),egl(+)]
+ x11-libs/libSM
+ >=x11-libs/startup-notification-0.7
+ media-libs/fontconfig
+
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.13:=
+ )
+ introspection? (
+ >=dev-libs/gobject-introspection-1.41.3:=
+ )
+ screencast? (
+ >=media-video/pipewire-0.3.0:=
+ )
+ sysprof? (
+ >=dev-util/sysprof-capture-3.35.2:3
+ )
+ udev? (
+ >=virtual/libudev-228:=
+ >=dev-libs/libgudev-232
+ )
+ wayland? (
+ >=dev-libs/libinput-1.7:=
+ >=dev-libs/wayland-1.13.0
+ >=dev-libs/wayland-protocols-1.19
+ || (
+ >=media-libs/mesa-24.1.0_rc1[opengl]
+ <media-libs/mesa-24.1.0_rc1[gbm(+),gles2]
+ )
+ x11-base/xwayland
+ x11-libs/libdrm
+
+ systemd? (
+ sys-apps/systemd
+ )
+ !systemd? (
+ sys-auth/elogind
+ )
+ video_cards_nvidia? (
+ gui-libs/egl-wayland
+ )
+ )
+"
+RDEPEND="${COMDEPEND}
+ gnome-extra/zenity
+"
+DEPEND="${COMDEPEND}
+ x11-base/xorg-proto
+
+ sysprof? (
+ dev-util/sysprof-common
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? (
+ dev-util/wayland-scanner
+ >=sys-kernel/linux-headers-4.4
+ x11-libs/libxcvt
+ )
+"
+
+PATCHES=(
+ # -Werror=incompatible-pointer-types
+ # https://bugs.gentoo.org/919091
+ # https://github.com/linuxmint/muffin/pull/683
+ "${FILESDIR}"/38919a88b2b8381f5b24b69742d1b9db32029c61.patch
+)
+
+src_prepare() {
+ default
+ python_fix_shebang src/backends/native/gen-default-modes.py
+}
+
+# Wayland is not supported upstream.
+src_configure() {
+ local emesonargs=(
+ -Dopengl=true
+ #opengl_libname
+ #gles2_libname
+ $(meson_use wayland gles2)
+ -Degl=true
+ -Dglx=true
+ $(meson_use wayland)
+ $(meson_use wayland native_backend)
+ $(meson_use screencast remote_desktop)
+ $(meson_use udev)
+ $(meson_use input_devices_wacom libwacom)
+ -Dpango_ft2=true
+ -Dstartup_notification=true
+ -Dsm=true
+ $(meson_use introspection)
+ $(meson_use test cogl_tests)
+ $(meson_use test clutter_tests)
+ # Wayland/Core tests cause issues. They attempt to access video hardware
+ # and leave /tmp/.X#-lock files behind.
+ -Dcore_tests=false # wayland
+ $(meson_use test tests)
+ $(meson_use sysprof profiler)
+ -Dinstalled_tests=false
+ #verbose
+ )
+
+ if use wayland; then
+ emesonargs+=(
+ $(meson_use video_cards_nvidia egl_device)
+ $(meson_use video_cards_nvidia wayland_eglstream)
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ glib-compile-schemas "${BUILD_DIR}"/data
+ GSETTINGS_SCHEMA_DIR="${BUILD_DIR}"/data virtx meson_src_test --no-suite flaky
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}