summaryrefslogtreecommitdiff
path: root/x11-wm/icewm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Manifest2
-rw-r--r--x11-wm/icewm/icewm-2.7.0.ebuild153
2 files changed, 155 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index d7f5ed30912f..0c6b1278259f 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,6 +1,8 @@
AUX icewm 33 BLAKE2B 5605658012ad8ed16bbd4cf0c4cb7cbe5204f73c20ef2c3d9fef1011a80b9e68863de64b45e4b043604b147c9d31f3f5d2617d067b694f5ec5329ad895472b0e SHA512 3fe619e59cc5d354242ccd85d3b1982dd7db6d0f6170f46f9d33975872f6d5a342a08d69db763162dc43681eedb96e9ba5075455bf54adf4fb86bf19887bf6e0
DIST icewm-2.5.0.tar.lz 1722504 BLAKE2B caf5d61559dd5bb25583bebeaca82e54049e2a97d8e5eeb93942908481f68614cfe55afd4041b5d60e58e732fef1694f67c5918a130bc55b252ebae67a51482a SHA512 1f59b4dbe90ca47031e5abf999cdb23a8e9ea956d5a76a0dde9b3489dec4530bf0ce72e10b337615d0bcadf04007b00a7db6f43082504bef65b109f9115d9f52
DIST icewm-2.6.0.tar.lz 1722772 BLAKE2B 4d7055b77d88d0731517b668f525161a97b571f68cf0b2944e9b364653cb022f0b29d664ccc9539d1807005ab8954aa3ce31244911c2fafaa673ef5afeb447f1 SHA512 fe491c8c59aa530d48a20134857c787eccfeda5bd9529e063d865bd3c5f243ef41fbecba40aa06e7fa8037af89839958095debebc5d9b1acc9b5670bd0e12eb6
+DIST icewm-2.7.0.tar.lz 1738471 BLAKE2B 407f5290329de99519b806db4bbc8895623d2930f37912db701170145579a1c2819b7ae2576b0aee146e8b006a12c78f7344224dd407ed7e8a1eba1cffc43ced SHA512 829673a3f7aa26fd7f74a9a8ab220548b6bb7724026517fa7ec1d5705fca2c0aa9339078d603242dbb2209c194a7a64aebcf55454aea5f8a20c4785e63e8cc3f
EBUILD icewm-2.5.0.ebuild 2952 BLAKE2B b0d75ba7ec27295593caa2bb47d51c518b35a81e95a53210b424f7632d197bb2cb6116feeee53f56348409589a13c2c288f01ddd76a98549643d051da89bfdee SHA512 016db15eb35afcc81a5312690790d43de8d6f936f99de63fc1efe6974adaf0f8a074bfb6e53711af9a561490686786e2e5b860d7f4fc678058eba44347f8c440
EBUILD icewm-2.6.0.ebuild 2956 BLAKE2B a29971bc37782d51dd81352475005d0860682ce1fa18ce04d9f69d67bdc1cefaf667a6179d58c63a6d39cb44f0971bd41ae54694896c37b0a3183a6a4fc360b4 SHA512 07b44baf1a7f48d9da2b8abdae82b3dda800662ce912f6f69cf1e7ea665407931aeb77b9f04e902b8862fc43790c4981bb1c57cd04c112cbed49991385a58174
+EBUILD icewm-2.7.0.ebuild 2956 BLAKE2B a29971bc37782d51dd81352475005d0860682ce1fa18ce04d9f69d67bdc1cefaf667a6179d58c63a6d39cb44f0971bd41ae54694896c37b0a3183a6a4fc360b4 SHA512 07b44baf1a7f48d9da2b8abdae82b3dda800662ce912f6f69cf1e7ea665407931aeb77b9f04e902b8862fc43790c4981bb1c57cd04c112cbed49991385a58174
MISC metadata.xml 747 BLAKE2B a986dc65f9b603519ef92fecc63cadd2921d6569e8735956a55ce91673426082e367664cce23c2b80cec19e0d997da357ac8f9d3d78c738ad92f42f6f426c225 SHA512 f9b84c60b780b5999c8a295b64bdf1bdb734108984e48f1271257cb35602df024a347560526de52f43ede16f67031551f4ae3f37401d3320e4dbdfb913e557fe
diff --git a/x11-wm/icewm/icewm-2.7.0.ebuild b/x11-wm/icewm/icewm-2.7.0.ebuild
new file mode 100644
index 000000000000..7b0d626e90a0
--- /dev/null
+++ b/x11-wm/icewm/icewm-2.7.0.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf imlib nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+#?? ( gdk-pixbuf imlib )
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf-xlib
+ >=x11-libs/gdk-pixbuf-2.42.0:2
+ )
+ !gdk-pixbuf? (
+ imlib? (
+ gnome-base/librsvg:2
+ media-libs/imlib2
+ )
+ !imlib? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+
+pkg_pretend() {
+ if use gdk-pixbuf && use imlib ; then
+ einfo 'Confilcting USE flags have been enabled:'
+ einfo '"gdk-pixbuf" and "imlib" exclude each other!'
+ einfo 'Using "gdk-pixbuf".'
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir="${EPREFIX}"/etc/icewm
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir="${EPREFIX}"/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable debug logevents)
+ $(use_enable gdk-pixbuf)
+ $(use_enable imlib imlib2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed \
+ -e "s:/icewm-\$(VERSION)::" \
+ -e "s:ungif:gif:" \
+ -i src/Makefile || die
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}