summaryrefslogtreecommitdiff
path: root/x11-wm/i3-gaps
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/i3-gaps')
-rw-r--r--x11-wm/i3-gaps/Manifest1
-rw-r--r--x11-wm/i3-gaps/i3-gaps-4.16.1-r1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-wm/i3-gaps/Manifest b/x11-wm/i3-gaps/Manifest
index 4cbdee3fc85b..54d7b3e1863b 100644
--- a/x11-wm/i3-gaps/Manifest
+++ b/x11-wm/i3-gaps/Manifest
@@ -1,4 +1,5 @@
AUX i3-gaps-4.16-musl.patch 2783 BLAKE2B 9dea47af64b78a77006d3aa641273aa7a77846d4425e1da17424528445450112ab275cdf7098ba8c2a76f1b08561b1d1a852cb9fd4ee4c61e53832ca702ad55d SHA512 fdff65255e7c9b30eefdbf032e04ba568d5b75a5b7dfc5fce1aecaac0f0d376b6bb4f87338e1eaf5f20b1c5882ebfc7349f8ab43c804349b5f5c626f9fc1d340
DIST i3-gaps-4.16.1.tar.gz 3983420 BLAKE2B f0d5a85b06ce33e1cc177af6da29f9cdf42ed754bb767aa9eaa5ab52f3b9f4f688d251f2a16fb222fc8cf5052e79859891c4185b1325b2ef6c1a813aa220468c SHA512 904c2f63c6a35573f13fd216625c1349ac71de70ae8f0440667c9d76048cdaf30a398ab358f2366d5f46502d87e801713b625cb509a05f39dbca1371d2b8d0e9
+EBUILD i3-gaps-4.16.1-r1.ebuild 1726 BLAKE2B ed6032ccaae1089c2c6a3874aaaaffc090d9480634a995166c7d214c628b562a4a96625d1a586126f1fa2a649fd5851ac3d75610bf185d9b84d2ef5653b8c3ee SHA512 024abbc3412fbba63864a16a0fcead29e855eebb72fc8a88b0d20e69bff8bf623058ac5d982d72af2438550bd8552393e71a1e617a450ee39071c8f350450df1
EBUILD i3-gaps-4.16.1.ebuild 1727 BLAKE2B baceb7766ffb3113638ac33ba2bc24135dc067649dff1be81911f56d697247f6f1c95edfed41c5b3f2ff70ccf189997676a53d0a3ba7b8b0c78077da979c447d SHA512 d17165aaeef4e73552052d6cb2c8e3877ae7978836eee3d349a20966ff70544fccbd3155778cf0e400ffe17be358b053f7a50b58f2166850f9ce04a477050516
MISC metadata.xml 322 BLAKE2B bdba5a4519158f97944784fc4e2813c1b8e8d4f6f90d43b3a935e8b2565ecc5d2444c4b7b4d11266263d25a76b5c2dba55ec6535fdaab03129bb022206abbce2 SHA512 d3ca96f88473d21b81c420795c6eee5dd41f43354de85fd549a9ae8127e46f10d00034730bf850ddd6df8607821d30fce17aa349b1b2575f43fd3303a2da1cf6
diff --git a/x11-wm/i3-gaps/i3-gaps-4.16.1-r1.ebuild b/x11-wm/i3-gaps/i3-gaps-4.16.1-r1.ebuild
new file mode 100644
index 000000000000..0f5113ed0c6a
--- /dev/null
+++ b/x11-wm/i3-gaps/i3-gaps-4.16.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source
+
+DESCRIPTION="i3 fork with gaps and some more features"
+HOMEPAGE="https://github.com/Airblader/i3"
+SRC_URI="https://github.com/Airblader/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/cairo[X,xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ virtual/pkgconfig
+"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS
+ !x11-wm/i3
+"
+
+S=${WORKDIR}/i3-${PV}
+
+DOCS=( RELEASE-NOTES-$(ver_cut 1-3) )
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-musl.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+}
+
+my_src_configure() {
+ # disable sanitizer: otherwise injects -O0 -g
+ local myeconfargs=(
+ $(use_enable doc docs)
+ --enable-debug=no
+ --enable-mans
+ --disable-sanitizers
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_install_all() {
+ doman "${BUILD_DIR}"/man/*.1
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3lock"
+ einfo " x11-misc/i3status"
+ einfo "Please refer to their description for additional info."
+}