summaryrefslogtreecommitdiff
path: root/x11-wm/dwm/dwm-6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/dwm/dwm-6.1-r1.ebuild')
-rw-r--r--x11-wm/dwm/dwm-6.1-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/x11-wm/dwm/dwm-6.1-r1.ebuild b/x11-wm/dwm/dwm-6.1-r1.ebuild
deleted file mode 100644
index c47fada5686c..000000000000
--- a/x11-wm/dwm/dwm-6.1-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit savedconfig toolchain-funcs
-
-DESCRIPTION="a dynamic window manager for X11"
-HOMEPAGE="https://dwm.suckless.org/"
-SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="xinerama"
-
-RDEPEND="
- media-libs/fontconfig
- x11-libs/libX11
- x11-libs/libXft
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- xinerama? ( x11-base/xorg-proto )
-"
-
-src_prepare() {
- default
-
- sed -i \
- -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall/" \
- -e "/^LDFLAGS/{s|=|+=|g;s|-s ||g}" \
- -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
- -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
- -e "s@/usr/X11R6/include@${EPREFIX}/usr/include/X11@" \
- -e "s@/usr/X11R6/lib@${EPREFIX}/usr/lib@" \
- -e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
- -e "s@/freetype2@ -I${EPREFIX}/usr/include/freetype2@" \
- config.mk || die
- sed -i \
- -e '/@echo CC/d' \
- -e 's|@${CC}|$(CC)|g' \
- Makefile || die
-
- restore_config config.h
-}
-
-src_compile() {
- if use xinerama; then
- emake CC=$(tc-getCC) dwm
- else
- emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" dwm
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/dwm-session2 dwm
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}"/dwm.desktop
-
- dodoc README
-
- save_config config.h
-}