summaryrefslogtreecommitdiff
path: root/x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild')
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild
new file mode 100644
index 000000000000..72805a2a9317
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200702.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }