summaryrefslogtreecommitdiff
path: root/x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild')
-rw-r--r--x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild b/x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild
index 44b2ece09bb9..8d7a1731ba67 100644
--- a/x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild
+++ b/x11-themes/nou-icon-theme/nou-icon-theme-09.02.08.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit gnome2-utils versionator
+inherit versionator xdg-utils
MY_PV="$(delete_all_version_separators ${PV})"
@@ -30,6 +30,10 @@ src_install() {
doins -r Nou
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}